Home » PLAYER'S HQ 1.13 » v1.13 Solutions,Tips & Spoilers » JA2 and v1.13 install (Game starts with fatal error)
JA2 and v1.13 install[message #354359] Tue, 14 August 2018 16:09 Go to next message
Gudgey

 
Messages:5
Registered:August 2018
Location: UK
Hi all

Just bought JA2 from GOG after reading all the good things about it, and after installing it, it ran and loaded the home screen without issues. However, after installing the 1.13 mod I can run the INI and set all the options, but now when I start the game I see a black screen for a few seconds before dropping back to the desktop with the following error:

JA2 Fatal Error

File : \sgp.cpp
Line: 761
Location: InitializeStandardGamingPlatform
Initializing Virtual File System failed

I'm running it on Windows 10 and have tried some other fixes as advised in other threads/forums, but none seem to work. Has anyone else come acroos this or has any suggestions?

I suppose I could unistall the lot and just play without the mod, but is sounds like I will really miss out angry

Thanks in advance
Re: JA2 and v1.13 install[message #354378 is a reply to message #354359] Wed, 15 August 2018 08:14 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
Hello and welcome to Bear's Pit happy

This will be your choice but if you haven's played any of the JA games before, you may want to play a game without 1.13 as it brings a lot of new features to the game. With 1.13 it's challenging even for veterans.

Very important : Make sure that your JA2 game is already patched to version 1.12. I don't know much but if it's in Windows 10, there is a folder with a couple of fixes in the 1.13 installation. Wine dll's and definitely make sure to set the INI.Editor to NOT play the intro video. You can also look in the JA2 root installation, not inside the Data folder, and delete the Intro.slf file.

Play Intro : False Windowed Mode : False. Game Resolution : I keep mine at 800x 600. Can go higher but everything looks a bit too small for my taste. Also right click on the INI.Editor shortcut, go to Properties and set it to Run as Administrator. Do not mess with compatibility, it's already taken care of by the modding geniuses in Bear's Pit and it's already part of the installation.

Did you install the latest version or an older one ? That could have caused issues as well. The 1.13 installation is very easy if you follow instructions.I hope that someone with more knowledge can help further.
I am running the game in Widows 10 also and have added the Wine.dll's and have removed Intro.slf. Also i have some mods such as Vengeance Reloaded, Arulco Revisited and Arulco Vacations and all of them are running beautifully happy

On a final note, do not give up, there are many videos on Youtube addressing issues like playing the game in Windows 10 and how ro install the game or about Wine.dll. Internet is your friend. For most of us it took a little searching till we got it right . I wish you best of luck and Welcome to the JA2 and 1.13 magic happy

[Updated on: Wed, 15 August 2018 08:19]




Just another old soldier.
Re: JA2 and v1.13 install[message #354380 is a reply to message #354378] Wed, 15 August 2018 13:43 Go to previous messageGo to next message
Gudgey

 
Messages:5
Registered:August 2018
Location: UK
Hi Gopas

Thank you for the reply. I followed a YouTube video on how to install the mod and it warned me about not unzipping the files directly into the JA2 folder and I believe it all installed correctly. Everything worked as in the video apart from running the JA2 program itself.

The GOG version is 1.12, and I've set the options in the INI as you've said.

Regarding the files, I have a couple of 'wine' files:

libwine.dll
wined3d.dll

Should there be more, or do I need to delete these files?

I do not have a intro.slf file in the JA2 folder, and don't remember deleting it. Is this file still required even though I disable the intro in the INI?

Thanks again for your help.


***UPDATE***
I looked in the Docs folder and there is only a Widows 8 fix in there, could I be using an old version?

[Updated on: Wed, 15 August 2018 20:16]

Re: JA2 and v1.13 install[message #354385 is a reply to message #354380] Thu, 16 August 2018 01:07 Go to previous messageGo to next message
Talion

 
Messages:17
Registered:June 2018
Hi, just to adress your last question: Did you download Depri's latest single click installer? Otherwise it's likely that you have the old 7609 stable. That stable is used for a lot of mods, but for vanilla i'd go for the latest version. I can't really help with the other issues. I only remember that after updating to 7609 you had to run the zpatch.bat file in the main folder for the update to be applied. If you didn't that would also result in an error.

Link to single click installer: https://onedrive.live.com/?id=13A6926EAC52083%21583&cid=013A6926EAC52083

or look for Depri's v.1.13 Builds Repository at the top of the page.




Re: JA2 and v1.13 install[message #354388 is a reply to message #354385] Thu, 16 August 2018 08:03 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
Hi again Gudgey

Yes, i also prefer to unzip and extract in folder on the desktop and then copy/paste on the JA2 root folder. The Windows 8 fix that comes with 1.13 also works on Windows 10. Use those dll's to overwrite the original ones IF it's necessary. As for the Intro.slf, you can delete it safely, it's not needed. If you want to keep it, set the INI.Editor to FALSE ,concerning the PLAY INTRO. The result will be the same.

Talion is right. Which version of 1.13 are you using ? Try the link he provided and select the SCI (Single Click Installer) with the newest date. Remember to play as adminsistrator if all else fails. You really shouldn't have any problems. Avoid adding other mods for now until the 1.13 works in your inrstallation and let us know.



Just another old soldier.
Re: JA2 and v1.13 install[message #354391 is a reply to message #354388] Thu, 16 August 2018 11:14 Go to previous messageGo to next message
Gudgey

 
Messages:5
Registered:August 2018
Location: UK
Thanks guys

I think I did install the stable one as I assumed that would be the most, well....stable! happy

I'll uninstall it all and try again this evening and let you know if it works.

[Updated on: Thu, 16 August 2018 11:14]

Re: JA2 and v1.13 install[message #354401 is a reply to message #354391] Thu, 16 August 2018 17:15 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
Personally i prefer the last stable 1.13 version from 2014. I will be using it until the new stable version comes to life and i suggest you do the same. Here's a link with everything you need. It's the 7435 with the 7609 update. It should run flawlessly. Try it and let me know. Read the page the link provides carefully. It contains many links, including the download of the stable 7435 and it's 7609 update.

It also includes step by step installation instructions.

http://ja2v113.pbworks.com/w/page/4218339/FrontPage

[Updated on: Thu, 16 August 2018 17:22]




Just another old soldier.
Re: JA2 and v1.13 install[message #354403 is a reply to message #354401] Thu, 16 August 2018 20:16 Go to previous messageGo to next message
silversurfer

 
Messages:2472
Registered:May 2009
Gopas wrote on Thu, 16 August 2018 16:15
Personally i prefer the last stable 1.13 version from 2014. I will be using it until the new stable version comes to life and i suggest you do the same.

ROFL You really think that there will be a new stable version? I love your optimism. The current development version is more stable than the 7609 build ever was. Most of the coders agree that creating a new "stable version" is too much hassle so it's highly unlikely that there will be one.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 and v1.13 install[message #354407 is a reply to message #354403] Fri, 17 August 2018 04:45 Go to previous messageGo to next message
edmortimer

 
Messages:1132
Registered:January 2015
Location: Home Free
If you use Sevenfm's executable for 7609 it is very stable. He has included many, if not all, the fixes of later builds in both his 7609+fix and 7609+AI. Additionally, his 7609+AI includes many improvements that make it a pleasure to play.




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: JA2 and v1.13 install[message #354410 is a reply to message #354407] Fri, 17 August 2018 13:46 Go to previous messageGo to next message
Gudgey

 
Messages:5
Registered:August 2018
Location: UK
That's a lot of versions+fixes, and so I'm a bit confused now as to which I should use? suprised
Re: JA2 and v1.13 install[message #354414 is a reply to message #354410] Fri, 17 August 2018 16:05 Go to previous messageGo to next message
edmortimer

 
Messages:1132
Registered:January 2015
Location: Home Free
Sevenfm's executable is simply the executable - just one file. You use it with the normal 7609 install, or a mod that uses 7609. The +fix executable has only bug fixes, while the +AI executable has all the bug fixes plus a lot of enhancements - mostly to the AI but also to other aspects of the game.




Arulco Vacations Blog

Arulco Vacations Bears Pit Forum


Re: JA2 and v1.13 install[message #354432 is a reply to message #354414] Sat, 18 August 2018 13:12 Go to previous messageGo to next message
Gudgey

 
Messages:5
Registered:August 2018
Location: UK
***FIXED***

Woohoo, it's working!

I went with the single installer Talion recommended and it launched first time with no fiddling around.

Thank you all for taking the time to help me out, can't wait to get stuck in big grin

[Updated on: Sat, 18 August 2018 13:13]

Re: JA2 and v1.13 install[message #354528 is a reply to message #354432] Sat, 25 August 2018 16:39 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
I am trying to use the newest JA2 8595 but when i try to run the game i get error and all of the INI.Editor's options are wrong. What am i doing wrong ? Do i need to install a clean JA2 without the 1.13 ?



Just another old soldier.
Re: JA2 and v1.13 install[message #354529 is a reply to message #354528] Sat, 25 August 2018 23:24 Go to previous messageGo to next message
silversurfer

 
Messages:2472
Registered:May 2009
Usually you would install a clean JA2 and then copy the contents of the latest SCI in top of that. It's explained in Depri's SCI thread.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 and v1.13 install[message #354532 is a reply to message #354529] Sun, 26 August 2018 12:11 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
The latest SCI is the 8595 ? It contains 3 exes and a readme. They do not overwrite the originals. I tried replacing them manually and the game screen shows all options wrong.



Just another old soldier.
Re: JA2 and v1.13 install[message #354534 is a reply to message #354532] Sun, 26 August 2018 14:21 Go to previous messageGo to next message
silversurfer

 
Messages:2472
Registered:May 2009
The latest SCI is 8595 on GameDir 2437 and is 373MB in size. That's not just 3 exes.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 and v1.13 install[message #354538 is a reply to message #354534] Sun, 26 August 2018 15:19 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
The 8595 i've got is from Depri's download page. Is that the right place to get the SCI is 8595 on GameDir 2437 and is 373MB in size. Or am i looking at the wrong place ? If yes, could you please point me to the right place to pick up the version you are telling me about ?



Just another old soldier.
Re: JA2 and v1.13 install[message #354542 is a reply to message #354538] Sun, 26 August 2018 17:21 Go to previous messageGo to next message
silversurfer

 
Messages:2472
Registered:May 2009
That's the page I'm referring to as well. I never downloaded any SCIs because I always update directly from SVN but I bet those 373MB hold more than just 3 exe files.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 and v1.13 install[message #354544 is a reply to message #354542] Sun, 26 August 2018 19:15 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
Hmmmm, i'll have another look, don't know why this happens. I have downloaded older versions and they were fine.

After checking again in Depri's downloads, there is a folder named Builds. The 8595 and the previous version do contain 3 exes and a readme. Downloaded an older version and it contains everything.

[Updated on: Sun, 26 August 2018 22:53]




Just another old soldier.
Re: JA2 and v1.13 install[message #354549 is a reply to message #354544] Sun, 26 August 2018 23:09 Go to previous messageGo to next message
Talion

 
Messages:17
Registered:June 2018
Try the SCI folder
Re: JA2 and v1.13 install[message #354553 is a reply to message #354549] Mon, 27 August 2018 13:46 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
Talion, where is the SCI folder at exactly ? A link pointing directly to it would be helpful. I don't know where to find the SCI you are telling me to use.If it the SCI folder from 2012 in Depri's OneDrive, i do own the original discs for the game. Not sure if it's the same but something from 2012, i don't know how relevant it can be.

Silversurfer, what is SVN and where can i find it ? A link and maybe instructions would be helpful. If the SVN is the link for Wildfire Maps at the bottom of your posts, my pc says it's a harmful site and to stay away from it. It doesn't let me access it anyway.

Thank you both happy

[Updated on: Mon, 27 August 2018 13:49]




Just another old soldier.
Re: JA2 and v1.13 install[message #354555 is a reply to message #354553] Mon, 27 August 2018 15:51 Go to previous messageGo to next message
Talion

 
Messages:17
Registered:June 2018
Yes, it's the folder in there. I think 2012 just means the folder was created at that time, but the files in there are up to date.

https://onedrive.live.com/?id=13A6926EAC52083%21583&cid=013A6926EAC52083

The newest is in the second row from 16. Aug Revision 8595_on_Gamedir_2437 with 373 MB volume.
Re: JA2 and v1.13 install[message #354557 is a reply to message #354555] Mon, 27 August 2018 16:53 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
@ Talion

If that is true it's great news. I'll have a look and let you know the results happy



Just another old soldier.
Re: JA2 and v1.13 install[message #354558 is a reply to message #354557] Mon, 27 August 2018 16:59 Go to previous messageGo to next message
Gopas

 
Messages:203
Registered:June 2016
Location: Norway
@ Talion

It's an older version , 8548 and it works fine, i've had it installed but uninstalled it in favor of 8595 which seems to be incomplete as of yet.
Sorry about all the trouble, i'll go with 8548 for now .



Just another old soldier.
Re: JA2 and v1.13 install[message #354559 is a reply to message #354558] Mon, 27 August 2018 18:41 Go to previous messageGo to next message
LatZee

 
Messages:108
Registered:December 2015
8595 is also there, take a better look cheeky 8548 is on top of list because it is the oldest SCI with the new name without unstable in it, 8595 is a couple editions below it, the Aug 16 one cheeky
Re: JA2 and v1.13 install[message #354560 is a reply to message #354559] Mon, 27 August 2018 22:12 Go to previous messageGo to next message
silversurfer

 
Messages:2472
Registered:May 2009
If you really want to keep up-to-date via SVN you need to install a tool to download from the SVN repository. Most players are probably using the Tortoise SVN client. There is a guide in this thread.

Unfortunately the opening post doesn't have the current SVN addresses but I posted them some time ago here. Unless you want to work with the source code yourself you only need the URL for the GameDir.
The GameDir does only have game data but no exe. So either you compile your own exe from the source code or you download the exe from Depri's repository which is linked in his "Builds and Packages" thread.

Using SVN may sound complicated but has nice benefits. You can read and search the change logs for each revision. You don't have to download the big whole GameDir for every update, just the few files that changed is enough. You can compare files to see changes directly in Tortoise. If you compile your own exe you can use the newest code without waiting for a new SCI (although Depri has a good update cycle).



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: JA2 and v1.13 install[message #354563 is a reply to message #354560] Mon, 27 August 2018 23:59 Go to previous messageGo to next message
townltu

 
Messages:316
Registered:December 2017
Location: here
silversurfer wrote on Mon, 27 August 2018 22:12
... you need to install a tool to download from the SVN repository. ...

Pardon me for OT "summoning", even more if you are the wrong contact.

Is it okay to grab the files with a crawler,
or does the increased consumption of resources cause any negative consequences like higher fee?
(I guess impact on other users data transfer rate is neglectable)
Re: JA2 and v1.13 install[message #354569 is a reply to message #354563] Tue, 28 August 2018 14:34 Go to previous messageGo to next message
Alred27
Messages:2
Registered:August 2018
Location: Maryland
Hi All,
I've been playing JA2 since the beginning and was a member here in the past. I picked up a new CPU with Windows10. last night I installed a clean version of the original game to a folder on my desk top. Interesting that it wouldn't load and play using the play disk. I then I download a revised version 8595 to my folder. I unzipped it inside of the folder. It appeared to work as it overwrote a number of the files. When I tried to start it would not boot to the game and after a few tries I got a fatal error. I tried to delete the file but Microsoft is blocking me from doing so. I am getting cleaned off today but some more clear instructions would be great.



Strength & Honor
Re: JA2 and v1.13 install[message #354591 is a reply to message #354569] Thu, 30 August 2018 03:22 Go to previous messageGo to next message
Talion

 
Messages:17
Registered:June 2018
Hi, after unpacking the mod there should be a Docs folder in the main Ja 2 Directory. It contains fixes for windows and a readme. I'd try if any of that helps with the issue.

Edit: I'd also start with the easier steps like compatibility mode and disabling the intro first.

[Updated on: Thu, 30 August 2018 03:37]

Re: JA2 and v1.13 install[message #354594 is a reply to message #354591] Thu, 30 August 2018 13:11 Go to previous messageGo to next message
LatZee

 
Messages:108
Registered:December 2015
.... and installing outside of windows controlled folders, so not on desktop, or more generally not in Program Files or Users folders.
Re: JA2 and v1.13 install[message #354598 is a reply to message #354594] Thu, 30 August 2018 16:56 Go to previous message
townltu

 
Messages:316
Registered:December 2017
Location: here
How about a parallel xp installation?
It solves nearly all other issues of OS incompatibility with elder programs,
and adding XP on top of 8 or 10 is a rather easy process, well described by several non dubious tech sites on the web.


Even better would be the rather difficult solution of an xp install on a usb device with fixed drive bit set,
e.g. in case hardware changes frequently or we have many computers.
Not sure whether the usb device solution circumvents the criminal warranty related contract clause of limitng a comp to one OS,
(at least in countries where governments bowed to the industry, or are the industry, and made it legal)
Previous Topic: Can't Find any Rod's or Springs, Looking for an external method to achieve this
Next Topic: hotkey problem (build - SCI_JA2v1.13_Revision_8626_on_GameDir_2448)
Goto Forum:
  


Current Time: Tue Dec 18 19:38:48 EET 2018

Total time taken to generate the page: 0.01615 seconds