Home » SIRTECH CLASSICS » Jagged Alliance 2 » JA2 Crashes, Bugs and Fixes » JA2 Virtualbox Windows XP SP3
JA2 Virtualbox Windows XP SP3[message #357027] Fri, 22 March 2019 14:23 Go to next message
Registered:March 2019

After trying to get JA2 to work without crashing for several weeks I at least managed to install Windows XP SP3 on VirtualBox.
The Game worked but it had the "Click the Quit-Button and have a Freeze" which sucks.
I read that you can only get rid of that bug if you install the 1.13 Mod which I did, but now the game doesn't even start anymore.
I get an error with something about the resolution.

I'm thinking about installing Windows 95 on Virtualbox, but that will probably be just a pain in the ass because W95 is slow and even on WXP copying the JA2 files takes about 10 minutes and W95 might also have the Quit-Button-Error.

Wine seems to work only on Linux.
I could try to install Linux on a second partition on my hard drive.

JA2 Stracciatella didn't work either. Whether I install it inside the game folder or outside I get an error that a certain temp file could not be produced or something. Maybe Stracciatella only works on Non-windows-OS.

On my W8.1 the best thing I could achieve was a game that had laggy laptop animations (going into the sector animation and enemy's are in the sector animation) with all compability settings, wined3d fix, and 1 cpu core.
But those lagging animations + having to restart everytime to play on one core is not fun.

I read that for some ppl downloading Microsoft Visual C++ 2005 and 2008 helped. I already have those but I dont have the 2005 x86.
Thats another thing I will probably try.

If anyone has any suggestions that would be nice.
Re: JA2 Virtualbox Windows XP SP3[message #357030 is a reply to message #357027] Fri, 22 March 2019 18:14 Go to previous messageGo to next message

Registered:December 2017
Location: here
If freeze on quit command is the only issue(as I understand) under virtual box XP SP3,
try to call windows task managervia ctrl+alt+del,
select the "processes" tab, r-click on JA2.exe and kill it.
Btw I did this many times under XP sp2+3 in JA2 vanilla days and it did not appear to fragment ram.

If the taskmanager window does not manage to come on top of JA2
although it is (most likely;) running and active:

If your machine does support suspend to ram/disk via shortcut, try the 1st, wake it up and the taskmanager window should be on top.
If thats not an option or does not help you can navigate "blind" in taskmanager.
By default the "applications" tab should be active, either you changed that before the freeze(the process list is more interesting anyway;),
else hit Shift+Tab to move the cursor from inside the apps window to the tab bar,
go to "process" tab with [right arrow].
To kill the desired program you must either know how much positions to scroll down,
or you can use the [J] key to jump directly to JA2.exe if it is the only or the 1st program in list that starts with a J,
(furtunately no default win stuff starts with J, so you should be fine)
and then use ALT+P -> Enter to kill the process.

Re: JA2 Virtualbox Windows XP SP3[message #357031 is a reply to message #357030] Fri, 22 March 2019 19:34 Go to previous message
Registered:March 2019
Second problem is I can't get full screen mode in Visualbox XP. Tried changing resolution but still didnt work. Screen is pretty small. (like half of my screen)
Screen goes black when I try to go full screen or increase the size of the screen of the virtual monitor.

Full screen works when im not playing but when im playing it doesnt work. Tried changing the resolution in the OS and in the virtual machine and in the ini of the game so that the resolutions are the same but it did not work.

[Updated on: Fri, 22 March 2019 19:36]

Previous Topic: I screwed up on GOG
Next Topic: Bugged my game during coordinated arrival
Goto Forum:

Current Time: Sat Jul 11 10:55:12 EEST 2020

Total time taken to generate the page: 0.01598 seconds