Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » All about modding JA2 » Few question regarding game modding, content (looking for a Weapon mod, and Wildfire)
Few question regarding game modding, content[message #357683] Wed, 24 July 2019 11:45 Go to next message
HellsWind

 
Messages:44
Registered:October 2018
Location: Netherlands
Hi.

I've been recently playing game JA2 1.13 and whilst I use the most recent build (8681) for a 'vanilla' 1.13 experience I was wondering if there was any weapon mods for the latest revision of the 1.13 mod and another question is if it's possible to play Wildfire (maps) in the latest build.

I've been playing Jagged Alliance 2 Gold - 1.13(8338)_beta+dbb_iov_929+its+arulco_revisited_v1.41_eng (Arulco Revisited) and have been having good fun with that with usually no problems but what I really would like to do is basically just like above but with wildfire maps, weapon mod (IoV is very good in this) and latest SCI-builds.

Is there a way to do this? As I can't figure out myself angry

[Updated on: Wed, 24 July 2019 11:47]

Re: Few question regarding game modding, content[message #357684 is a reply to message #357683] Wed, 24 July 2019 19:30 Go to previous messageGo to next message
silversurfer

 
Messages:2603
Registered:May 2009
You can use the WF maps 6.07 with the current JA2 1.13 build. SVN link to the current WF6.07 maps is in my sig. Installation instructions are in the readme file on SVN.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Few question regarding game modding, content[message #357685 is a reply to message #357684] Wed, 24 July 2019 20:16 Go to previous messageGo to next message
HellsWind

 
Messages:44
Registered:October 2018
Location: Netherlands
It wasn't clear at first but I've done it and I must say that it works like a charm because it doesn't seem to be buggy and it's got a lot of WTF moments, which is great (enemy AI is great in TAC-screen also in game fights). Thanks for the hard work put into it, I imagine it must be great doing it.

However, I'm trying to get the maps from the SVN to work with the older versions of the game I believe is from another website (Name, is: 1.13(8338)_beta+dbb_iov_929+its_eng) because it's got the IoV mod, but I can't get it working it shows me old Wildfire maps not the newer ones with more detail, but the IoV weapon mod works fine.

I am wondering 2 things; could you please explain to me what I'm doing wrong (why won't Wildfire 'new' maps work with '8338' build?), and is there any (weapon) mod planned for 1.13? (that would be nice)

(and thanks for the reply earlier big grin)

[Updated on: Wed, 24 July 2019 20:19]

Re: Few question regarding game modding, content[message #357686 is a reply to message #357685] Wed, 24 July 2019 21:42 Go to previous messageGo to next message
silversurfer

 
Messages:2603
Registered:May 2009
I don't know iov so I can't say what is necessary to make it work with WF maps. It probably requires some sort of merge and manual adjustments, at least a manual modification of the vfs_config file to incorporate iov and WF maps into the same config. The current JA2 1.13 build is 8682 and the WF maps are designed to work with that. The maps may have some new definitions that don't work with the 8338 build, simply because the code for those didn't exist at the time. Also placed items on the map may not be what is expected because the same item ID in 1.13 may represent a different item in iov. I guess it takes some experimenting to see if it can work together.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: Few question regarding game modding, content[message #357693 is a reply to message #357686] Fri, 26 July 2019 05:08 Go to previous message
HellsWind

 
Messages:44
Registered:October 2018
Location: Netherlands
Okay, understood but in the meanwhile that's just what I did. I've tried to 'tinker' with 'it' and had some results.

I've tried and managed to, get Jagged Alliance 2 Gold - 1.13(8338)_beta+dbb_iov_929+its_eng working with Wildfire 6.07 maps. This is how I did.

I downloaded Ja2 1.13 IoV from https://jagged-alliance.pl/plik625/ and installed this into a directory.

I downloaded from your SVN Wildfire Maps, put the 6.07 version in the game directory. (Data-WildFire6.07 & UserProfile_JA2113WF607) I did not copy over file Ja2.ini, I left the original in because this doesn't matter, files are the same (copying I believe brings errors but the Ini Editor updates the file Ja2.ini by itself I noticed I think)

Now I started playing but got a few errors along the way, first being off that I noticed that the maps were old maps, but remembered your ReadMe, file from (JA2 1.13-Wildfire6.07 Maps ReadMe) and edited the *.xml files back to their old versions.

This has made the... everything work with new (6.07, I think) maps, but I've encountered new problems along the way.


A crash regarding something like ''getarmsdealerittemtype... 1962.adf 0'', but managed to I think fix this by adding the following row of lines at the end of vfs_config.JA2113Wildfire607.ini

[LOC_WF607_7z]
TYPE = LIBRARY
PATH = Mods/Data-WF607.7z
MOUNT_POINT =

Which I thought solved this problem, which happened on the tac. map, so I played on but.

Got to Ira and when recruiting her the game would crash.

So I fixed that by copying gameinit.lua from Jagged Alliance 2 Gold - 1.13(8338)_beta+dbb_iov_929+its_eng\Data-1.13 to Jagged Alliance 2 Gold - 1.13(8338)_beta+dbb_iov_929+its_eng\Data-WildFire6.07, replacing the original file and after which in game I could recruit Ira with no crash.

Now at the airport playing game with Drop_All and getting some weapons/money.

Will possibly play the game on and perhaps update here if this patchwork stays waterproof ea. in working order.
I've managed to achieve the results through research ea. reading a lot (of various posts) through the web and trying out myself. (a couple of times)

Uhm, thanks for clearing that up above though Surf.

Edit, the Airfield in Drassen is accord to 6.07 maps but as soon as I move down into the town the town, with the cafe is of old maps. cheeky Not working 100%, alas.

Edit #2, coming back some time later, I find out that on a previous install of the game (8338, same as above basically) the maps work everywhere seemingly but I don't know if this is due to way of install order or just 'luck' but one thing is that somehow it works, and I think by following the steps above there is some chance that it will work as desired.

Got two versions of the same but an older installation of it works, don't understand fully but as long as it works... I'm a happy camper. Maybe useful instructions for another one who wants to tweak around with.

[Updated on: Fri, 26 July 2019 08:58]

Previous Topic: New Mod Announcment (Tuscany)
Next Topic: Which JA2 version/mod should I play ?
Goto Forum:
  


Current Time: Wed Dec 11 07:26:29 EET 2019

Total time taken to generate the page: 0.01155 seconds