Home » SIRTECH CLASSICS » Jagged Alliance 2 » JA2 Crashes, Bugs and Fixes » Windows Vista, problem...
Windows Vista, problem...[message #136139] Mon, 16 April 2007 15:33 Go to next message
pCz3r0 is currently offline pCz3r0

 
Messages:10
Registered:April 2007
Hi...
I instaled Windows Vista Ultimate yesterday and can say it look really nice. I was excited so I decided to play Jagged Alliance 2 (1.13) (who doesn't like to play JA2 under excitement?), but when the game started it had a graphic problem...
The screen looks like the resolution is to high for the computer...
Here are the things I tried:
-Change resolutions in the game;
-Disabled/enabled V-Sync;
-Changed compatibility in the game proprietis.

Plz, someone help me, I can't go too long without JA2... tnky

Report message to a moderator

Private
Re: Windows Vista, problem...[message #136148] Mon, 16 April 2007 18:30 Go to previous messageGo to next message
shed23 is currently offline shed23

 
Messages:130
Registered:October 2004
Location: U.K.
Although I cannot help you here, as I do not have Vista installed, this does throw open a question I have been putting off.

Is JA113 Vista compliant?
Looking at the above sows the seeds of doubt.

Ultimately, I suppose, we will all have to change over to this Vista.

But, I have a cunning plan!
I am going to keep my 'old set-up' (XP based) and build my own Vista based set-up and link the buggers together, hopefully!!!

Report message to a moderator

Sergeant
Re: Windows Vista, problem...[message #136151] Mon, 16 April 2007 19:19 Go to previous messageGo to next message
Headrock

 
Messages:1771
Registered:March 2006
Location: Jerusalem
First of all, Red_dot, you might be experiencing a different refresh-rate, rather than a different resolution. You'll need to describe the problem in more detail if you want anyone to give you a good answer, but one thing you could try is forcing the game to use the correct resolution. This isn't too simple to do, although if you've got an ATI graphics card on your machine, you could try opening the Catalyst Control Center, having a look around, and trying to find the option that forces all programs to use the same refresh rate as the desktop (this is usually around 70-75hz for good performance on most screens). This will resolve the issue if what you're seeing in JA2 is the screen flickering very quickly (like it's shimmering lightly, gives headaches), which means the refresh rate is too low. If the game tries to change the resolution of the screen, then fails and crashes (or simply doesn't load properly), then the problem could be worse, although you COULD try changing your desktop resolution to 1024x768 with 16 bit color depth, and seeing whether or not the game will load (sort of set your entire computer to the same resolution as the game, so it doesn't have to switch...).

Very interesting to hear if any of this works, although a permanent solution to Vista may soon become a neccesity to this project...

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #136164] Mon, 16 April 2007 23:39 Go to previous messageGo to next message
pCz3r0 is currently offline pCz3r0

 
Messages:10
Registered:April 2007
Hey...
Headrock, I tried all the possible resolutions on all posible situations I know... but it could be a Refresh rate problem, cause the monitor changes de RR to 40 in the game, and goes back to 70 off the game.

Here are some pics of the problem (they might not work, never had much luck with it)


http://img236.imageshack.us/img236/415/ja2bugvista01qu1.jpg
http://img236.imageshack.us/img236/7623/ja2bugvista02hc7.jpg


I'm still going to try the catalyst menu and reinstall drivers...

I'm getting desperate... I need JA2

Report message to a moderator

Private
Re: Windows Vista, problem...[message #136174] Tue, 17 April 2007 02:41 Go to previous messageGo to next message
Marlboro Man

 
Messages:1171
Registered:October 2005
Location: USA
Ooooooooooo look at the pretty colors. Smile)))) Looks like your pc is on an acid trip. Smile))))

Looks like a driver issue and or RR as headrock stated. If your using a digital flat panel I think the RR is maxed at 60 hz. If you go over that then you might have some problems.

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #136186] Tue, 17 April 2007 09:38 Go to previous messageGo to next message
shed23 is currently offline shed23

 
Messages:130
Registered:October 2004
Location: U.K.
Not too sure if this is even relevant, but from what I can understand from other people, is that a lot of 'third party' software/hardware suppliers have not yet supplied Vista compliant drivers.
It would appear that NVidea is one in particular. Might be an idea to keep checking for relevant driver up-dates.

Trouble is, Vista is 'too new'.
It needs 6 - 12 months out in the 'wilds' to iron out most of its problems.

Best of luck. If I was denied my regular 'fix' of JA2, I would probably be in some kind of re-hab!!

Report message to a moderator

Sergeant
Re: Windows Vista, problem...[message #136245] Tue, 17 April 2007 22:49 Go to previous messageGo to next message
pCz3r0 is currently offline pCz3r0

 
Messages:10
Registered:April 2007
Well looks like I'm going to be without JA2 Sad, I will have to wait for a fix and for JA3 (if that doesn't work in Vista, I'll kill the creators!)...

tnks for the help and I'm starting re-hab tomorrow xD!

Report message to a moderator

Private
Re: Windows Vista, problem...[message #136248] Tue, 17 April 2007 23:28 Go to previous messageGo to next message
Marlboro Man

 
Messages:1171
Registered:October 2005
Location: USA
Well. Your call then. I would trash vista myself and wait about a year. Until then I would put XP back on.

Nothing worse than an incomplete piece of garbage, that wastes your time, like vista is at the moment.

I don't understand these big corporations releasing garbage before it's ready. It's bad enough when they release garbage and call it complete and great.

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #136281] Wed, 18 April 2007 07:45 Go to previous messageGo to next message
Khor1255 is currently offline Khor1255

 
Messages:1818
Registered:August 2003
Location: Pleasantville, NJ
I've even known vanilla Ja2 to have problems running on an XP system. Fortunately all of mine have worked great on XP but a friend of mine has a computer running 98 specifically for Ja2. It seems different software architecture can interfear with Ja2 maybe because it uses so many .dlls and system 32 routines (wild guess).

You can usually get ahold of a Pentium 3 system fairly cheap. Since all you really need is about 10 gigs and 128 mb of ram to run the game and a couple of mods without problem I suspect you should be able to throw a rig like this together for less than $100.

I was hoping Vista would actually be an improvement and not just another os designed to wipe your ass but that does not seem to be the case.

It would be awesome if someone created an os capable of fully interfacing with windows but that ran very lean and straightforeward. This is the type of os I'm waiting for. Till then, I'll stick with XP.

Report message to a moderator

Sergeant Major
Re: Windows Vista, problem...[message #136288] Wed, 18 April 2007 10:26 Go to previous messageGo to next message
Headrock

 
Messages:1771
Registered:March 2006
Location: Jerusalem
Red_Dot - I would assume that the refresh rate is the problem. 40 is well below normal, and I believe you just need to find the controls to force your machine to use your normal rate of 70.

However I would like to ask first, as your screenshots from the game are all in 640x480 format: You said that you have JA2 1.13, have you tried upping the game's target resolution, rather than the screen's? The lower the resolution the game's trying to achieve, the more likely a modern GFX card or screen will have problems with it.

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #136335] Wed, 18 April 2007 21:06 Go to previous messageGo to next message
pCz3r0 is currently offline pCz3r0

 
Messages:10
Registered:April 2007
I'm still trying to find a way to set global Refresh Rate, and yes I tried all the Res in the game (JA2options in the JA2 file) and nothing still the same...

I guess I'll have to mount my older computer and play it there.

I'll keep searching and if I find anything I'll say something, for those in the same situation.

Report message to a moderator

Private
Re: Windows Vista, problem...[message #136345] Wed, 18 April 2007 23:41 Go to previous messageGo to next message
Headrock

 
Messages:1771
Registered:March 2006
Location: Jerusalem
If you are indeed using an ATI card, the Catalyst Control Center can do it, as I mentioned before. Set the program to Advanced mode (there's a button) and look on the left side for "Display Options". It would be the top option, to force a refresh rate. I have no idea how to do it with nVidia cards.

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #136351] Thu, 19 April 2007 01:53 Go to previous messageGo to next message
pCz3r0 is currently offline pCz3r0

 
Messages:10
Registered:April 2007
I do have a ati card (x1600), but the problem is that I can't open the catalyst control center :S

Report message to a moderator

Private
Re: Windows Vista, problem...[message #136361] Thu, 19 April 2007 07:32 Go to previous messageGo to next message
Headrock

 
Messages:1771
Registered:March 2006
Location: Jerusalem
Hmmm... how odd. What happens when you try to? HAve you tried downloading the latest CCC version?

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #136364] Thu, 19 April 2007 10:45 Go to previous messageGo to next message
Spinx is currently offline Spinx

 
Messages:34
Registered:February 2007
Location: Washington state
Guys I can say for sure that JA2 does indeed run on vista. After I got over the inital problem of not being able to change the INI it worked for me with out any problem. I have no idea how i fixed that but it worked its self out. I Havn't had any major problems running games on Vista for the most part. The only problem I ended up having was I updated nvidia drivers and coudln't deal with my moniter but that wasnt vista related.

[Updated on: Thu, 19 April 2007 10:47] by Moderator

Report message to a moderator

Private 1st Class
Re: Windows Vista, problem...[message #136409] Thu, 19 April 2007 22:32 Go to previous messageGo to next message
pCz3r0 is currently offline pCz3r0

 
Messages:10
Registered:April 2007
Spinx
Guys I can say for sure that JA2 does indeed run on vista. After I got over the inital problem of not being able to change the INI it worked for me with out any problem. I have no idea how i fixed that but it worked its self out. I Havn't had any major problems running games on Vista for the most part. The only problem I ended up having was I updated nvidia drivers and coudln't deal with my moniter but that wasnt vista related.

Really? Damn... can you try to remember what you changed?...
It can be because of the driver, I downloaded the lateste driver from ATI, maybe that's the problem...

Report message to a moderator

Private
Re: Windows Vista, problem...[message #136426] Fri, 20 April 2007 01:50 Go to previous messageGo to next message
Headrock

 
Messages:1771
Registered:March 2006
Location: Jerusalem
Yeah, that's always possible. The drivers for ATI cards past version 6 have a lot of strange bugs, and although they are usually important for newer games, I wouldn't be surprised if on Vista it's possible to find all sorts of glitches (I would've expected glitches on Vista regardless Smile ). Fortunately it does mean that you'll probably have a reasonably good chance of finding older drivers out there, since apparently they're still in demand. You could have a go at that. Although I still would want to hear what's wrong with your current CCC. What exactly is the problem with running it?

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #137071] Sat, 28 April 2007 16:55 Go to previous messageGo to next message
bagofmilk is currently offline bagofmilk
Messages:1
Registered:April 2007
I too have vista. I ran the 1.13 mod. and everything worked fine UNTIL i checked out Bobby Ray's. Everytime i try to scroll through his inventory the game crashes. Is this v1.13's fault or vista's. Any fixes???

Report message to a moderator

Civilian
Re: Windows Vista, problem...[message #137100] Sat, 28 April 2007 22:53 Go to previous messageGo to next message
pCz3r0 is currently offline pCz3r0

 
Messages:10
Registered:April 2007
I think that's a 1.13 bug, it can be fixed...
What kind of Graphic card do you use, ATI or NVIDIA?

Report message to a moderator

Private
Re: Windows Vista, problem...[message #138737] Mon, 14 May 2007 14:16 Go to previous messageGo to next message
BasiC_101 is currently offline BasiC_101

 
Messages:27
Registered:September 2006
Location: South Africa

Just make sure you have all the latest Windows Vista drivers, their is not really a lot of "vista support" for systems older than say 2 years. They keep updating though, keep checking.

Report message to a moderator

Private 1st Class
Re: Windows Vista, problem...[message #201043] Fri, 07 November 2008 04:13 Go to previous messageGo to next message
pheloncab is currently offline pheloncab

 
Messages:278
Registered:August 2004
Location: So. Cal. or texas
Solution found for catalyst driver issue:

disable the Catalyst AI:

Report message to a moderator

Master Sergeant
Re: Windows Vista, problem...[message #201048] Fri, 07 November 2008 04:58 Go to previous messageGo to next message
Headrock

 
Messages:1771
Registered:March 2006
Location: Jerusalem
Like I've always said, ATI make great GFX cards, but they suck at software.

Report message to a moderator

Sergeant Major

Re: Windows Vista, problem...[message #203836] Thu, 11 December 2008 16:37 Go to previous messageGo to next message
Kaerar is currently offline Kaerar

 
Messages:2026
Registered:January 2003
Location: Australia :D
Yeah Catalyst Control Centre is shite.

Get the driver only download from ATI and then use ATI Tray Tools (available at Guru3D.com) to configure them properly.

Report message to a moderator

Lieutenant

Re: Windows Vista, problem...[message #203851] Thu, 11 December 2008 19:20 Go to previous messageGo to next message
lockie is currently offline lockie

 
Messages:3751
Registered:February 2006
Location: Scotland
Glad to see you back mate , tie me kangaroo down sport ........ :ok:

Report message to a moderator

Captain

Re: Windows Vista, problem...[message #203885] Fri, 12 December 2008 09:39 Go to previous message
Kaerar is currently offline Kaerar

 
Messages:2026
Registered:January 2003
Location: Australia :D
Yeah I'm back, there is only so much time you can stay away from this very old but very intriguing game Very Happy

For instance I found out for the first time ever (this happens a lot) that there is an armour dealer in Cambria. I only ever used Cambria as a stop off between Grumm and getting that Central SAM. Never done most of the quests there!

Report message to a moderator

Lieutenant

Previous Topic: Funny bug
Next Topic: A problem with the WF map MOD for 1.13
Goto Forum:
  


Current Time: Wed Feb 01 21:27:08 EET 2023

Total time taken to generate the page: 0.00892 seconds