Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » UC/DL 1.13 & AFS » UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2013/03/07)
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305050] Mon, 21 May 2012 17:59 Go to previous messageGo to next message
Headhunter is currently offline Headhunter

 
Messages:264
Registered:November 2009
Location: Sweden
Quote:
XML Editor

Preparation Instructions

Report message to a moderator

Master Sergeant
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305059] Mon, 21 May 2012 19:45 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Headhunter
... all I get is "Object reference not set to an instance of an object" when I try to start the editor.


Ok, I replicated the bug, and I think I figured out what it is - my edits for v3.65.2 were done entirely in Notepad++ (as they covered rev. 5xxx features).

On the Windows XP test machine, clean install of JA2 with v1.13 Rev. 4780, but I copied the UC-1.13 files from my Rev 5280 test install, resulted in the "Object reference not set to an instance of an object" error, which I suspect is due to how I manually introduced some new tags.

Installed UC-1.13 v3.65.1 from the uploaded 7zip archive, and the XML Editor works fine. Now since the forum move, I cannot seem to find the posting for v3.65.2...

EDIT: found the reason in my ModDB posting for the mod, and if you are running the mod under the last Stable v1.13, Rev. 4780 (with XML Editor 0.60), then there is no reason for you to apply the v3.65.2 patch.

*** UC-1.13 v3.65.2 20120501 SVN-SCI Patch Only apply this patch if you are using one of the SVN Single Click Installers (Rev.5xxx). ***

- allows use of Scope Modes feature (not tested in UC-1.13)
- fixes detonator items, 223 and 224, not working under v1.13 Rev.5xxx by adding 65536

[Updated on: Mon, 21 May 2012 19:51] by Moderator

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305061] Mon, 21 May 2012 19:51 Go to previous messageGo to next message
Headhunter is currently offline Headhunter

 
Messages:264
Registered:November 2009
Location: Sweden
Hmm, I edited using just good old Notepad, maybe that's the issue...



Oh, and:

http://www.ja-galaxy-forum.com/board/ubbthreads.php?ubb=showflat&Number=236264#Post236264

Right at the top.

Report message to a moderator

Master Sergeant
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305062] Mon, 21 May 2012 20:00 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Headhunter
Hmm, I edited using just good old Notepad, maybe that's the issue...


Possibly related, but I got the error with the .2 patch, and I know it was created outside any XML Editor.

v3.65.1 was produced with the HAM 5 XML Editor as it is compatible with both Stable Rev.4780 tags as well as the HAM5 specific tags. XML's saved by the HAM 5 XML Editor are backward compatible with the Rev.4780 XML Editor, although the Rev.4780 XML Editor will strip out the HAM5 tags.

XML edits for v3.65.2 was produced with Notepad++ as I didn't want to bother with full testing for a simple patch. If you are not testing the mod under Rev.5xxx, there is no need for the v3.65.2 patch. However as Sweeper the mercenary found, the mod is not compatible with Rev.5xxx XML Editors.

Again, I'm not bothering with making the release compatible with Rev.5xxx XML Editor's till I move the project onto v4.xx. I simply do not have the time.

[Updated on: Mon, 21 May 2012 20:01] by Moderator

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305065] Mon, 21 May 2012 20:46 Go to previous messageGo to next message
Sweeper is currently offline Sweeper

 
Messages:99
Registered:March 2002
Location: Namsos, Tr
Well no big rush on the XML editor, the small fixes I wanted to do have already been done with Notepad++.
Main reason I went with a later build was to get rid of some of the annoying crashing bugs that 4870 has, although I still have the 4870 install as well so I am good in that department too Razz

Report message to a moderator

Corporal 1st Class
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305079] Tue, 22 May 2012 00:58 Go to previous messageGo to next message
Headhunter is currently offline Headhunter

 
Messages:264
Registered:November 2009
Location: Sweden
I got it working now, it was the patch that did it.

wil473
Again, I'm not bothering with making the release compatible with Rev.5xxx XML Editor's till I move the project onto v4.xx. I simply do not have the time.


As Sweeper said, no rush at all. It's actually not that important to me, it's just that I haven't played UC-1.13 in a while and I wanted to remind myself of what equipment there was before I jumped in. Then I ran into the issue and I wanted to know how to fix it.

Anyway, thanks for the help! Smile

Report message to a moderator

Master Sergeant
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305734] Fri, 08 June 2012 04:06 Go to previous messageGo to next message
Olddog is currently offline Olddog

 
Messages:21
Registered:May 2007
Location: Outback Australia
Hey Wil, Graet job on UC1.13 - I have been having a lot of fun with it after being away for a while. So far I have a number of bugs to report though none are yet gamebreakers. Firstly I am using the recommended base install from the UC 1.13 Hybrid page as at feb 12.

The bugs are these:

1) Several times when using the jeep, passengers disembark but are then unable to move at all getting a Path Blocked error. It can be resolved by moving the affected mercs to the next grid on the campaign screen then zooming to tactical.

2) The vanishing sector inventory problem reported earlier in this thread. It seems to happen when moving on the campaign screen then zooming to tactical view. i do not know if this is significant but the only items remaining are always the Folding Stock sets. If those are not present the inventory does not seem to disappear. Solution is to move to a nearby grid with no valuable items then use tactical screen to move to next grid.

3) Sydney hitting with a shotgun often (30-40% or so) causes ctd. Solution is either to not use shotguns or save before attempting shot.

4) Not sure if this last one is a bug - not everyone can equip Backpack or Tactical pack. I bought an Alice Pack and an Aruc Backpac but was unable to equip them on just anyone. Rude Dog could not equip the backpack but Fox could. Buns could not equip the Alice Pack.

None of these are gamebreakers merely minor inconveniences in an otherwise excellent conversion. I forget how long its been since testing the Militia Factions Mod (which was also a lot of fun, but I can only imagine how much work UC 1.13 was so,againcongratulations on your hard work.

Report message to a moderator

Private 1st Class
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305735] Fri, 08 June 2012 10:29 Go to previous messageGo to next message
wanne (aka RoWa21) is currently offline wanne (aka RoWa21)

 
Messages:1961
Registered:October 2005
Location: Austria
@Olddog: Bug #2 is already fixed. That was a problem in the 1.13 source code.

Report message to a moderator

Sergeant Major

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305736] Fri, 08 June 2012 11:32 Go to previous messageGo to next message
DepressivesBrot is currently offline DepressivesBrot

 
Messages:3658
Registered:July 2009
#4 is usually intentional. I don't know wil's exact setup for the allowed combinations but see it as both packs are rather large and can't be worn at the same time.

Report message to a moderator

Captain

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #305738] Fri, 08 June 2012 14:24 Go to previous messageGo to next message
CapnJack is currently offline CapnJack

 
Messages:56
Registered:June 2012
I still seem to be getting disappearing sector inventory items in Rev 5280 w/ UC1.13. The entire inventory doesn't disappear, only select items I've noticed disappearing. For instance one time a box of .357 ammo disappeared then another time one of my backpacks disappeared containing a crowbar, toolbox, and Mirna Kirniak's head (just as well as it was starting to smell).

I'm not sure what's triggering this to happen but I know that I dropped the backpack during battle, once it ended did a bit of container searching. All I know is I realized later I had forgot it in that sector and went to its sector inventory page only to find it not there. I checked all the nearby sectors just to ensure I didn't forget where I dropped it, no dice. At first I thought I was just going crazy with the .357 ammo but now I KNOW that I had another item disappear. I did make a small change to the Items.xml to get Crepagen/boost working with the new drug system but that's it.

EDIT:Come to think of it looking at the sector in question again it does look like other items disappeared. A few Flak Jackets that were on the ground from dead enemies seem to be gone as well. So maybe something I did reset the inventory between the end of the battle and before I searched the containers.

[Updated on: Fri, 08 June 2012 14:31] by Moderator

Report message to a moderator

Corporal
Re: UC-1.13 Bug Reports (2011/07/30 to 2011/--/--)[message #310432] Thu, 20 September 2012 12:12 Go to previous messageGo to next message
Voteslave is currently offline Voteslave

 
Messages:28
Registered:July 2005
Hi all

Bobby Ray's crashs game

I am using : Most Recent Version: 20110619 Urban Chaos-1.13 v3.55 with 3.56 patch.

Just taken the airport at Calisto and had the email saying BR was open. I can load up the website but as soon as i click on one of the categories the game crashes (except guns where i can get into the first screen but it then crashes if i try to load the next screen).

The game has worked perfectly so.

Any ideas what may be causing this and how to fix?


thanks

juat found this in a log file if it helps:

[9.84627] : ERROR : ========== Thu Sep 20 11:00:11 2012 ==========
File : ..\src\Core\vfs_file_raii.cpp
Line : 34
Location : vfs::COpenReadFile::COpenReadFile

file "AMBIENT\32.bad" does not exist

[Updated on: Thu, 20 September 2012 13:52] by Moderator

Report message to a moderator

Private 1st Class
Re: UC-1.13 Bug Reports (2011/07/30 to 2011/--/--)[message #310434] Thu, 20 September 2012 14:00 Go to previous messageGo to next message
wolf00 is currently offline wolf00

 
Messages:1148
Registered:September 2006
Location: Czech Republic

curent uc is 3.70 adcap mod 4 & actual svn ... you using outdated relase sorry.... here is dowload link for actual urban chaos mod relase http://www.mediafire.com/?6yrvbp3zri4ggnb

http://www.bears-pit.com/board/ubbthreads.php/topics/309684/Re_Urban_Chaos_1_13_v3_70_ADCA.html#Post309684 instructions for install ...

Report message to a moderator

Sergeant Major
Re: UC-1.13 Bug Reports (2011/07/30 to 2011/--/--)[message #310436] Thu, 20 September 2012 14:46 Go to previous messageGo to next message
Voteslave is currently offline Voteslave

 
Messages:28
Registered:July 2005
thanks - i missed that, must have been following some old links

if i just install over current install is that ok?
and any idea if its save game compatible?

cheers

Report message to a moderator

Private 1st Class
Re: UC-1.13 Bug Reports (2011/07/30 to 2011/--/--)[message #310437] Thu, 20 September 2012 15:28 Go to previous messageGo to next message
wolf00 is currently offline wolf00

 
Messages:1148
Registered:September 2006
Location: Czech Republic

i think you need fresh new instal & start new game ...

Report message to a moderator

Sergeant Major
Re: UC-1.13 Bug Reports (2011/07/30 to 2011/--/--)[message #310457] Thu, 20 September 2012 21:00 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Some questions Voteslave:

1) What version of JA2 v1.13 is all this being dropped over?

2) What other mods do you have installed besides UC-1.13?

There are some major changes to how graphics are handled between the last "official" release of Urban Chaos-1.13, v3.65.1 (Full) 20120421 (v3.65.2 is only to be used under specific circumstances, see question 1) and the experimental ADCAP releases.

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #310770] Sun, 30 September 2012 02:57 Go to previous messageGo to next message
Smigoz is currently offline Smigoz

 
Messages:18
Registered:March 2012
Game crashes right at the start with an assertion failure message. Can't do anything after recruiting the mercs basically.
I downloaded 1.13 here (the patch too):

http://ja2v113.pbworks.com/w/page/4218339/FrontPage

I got UC data from here and renamed it Data-UC
http://kermi.pp.fi/JA_2/Mods_Vanilla/Urban_Chaos/

I downloaded this version of UC:

http://www.mediafire.com/?udu4t8k7z6uu261

Do i also need Dedrianna lives and Alrulco Folding Stock mod? I didn't download them.

Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #310789] Sun, 30 September 2012 20:00 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Smigoz, what folder did you install everything into? In other words, what is the full path of where your Jagged Alliance 2 installation?

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #310791] Sun, 30 September 2012 21:56 Go to previous messageGo to next message
Smigoz is currently offline Smigoz

 
Messages:18
Registered:March 2012
C:\Jagged Alliance 2 UC

I had my original install in Program Files (x86) but i copied it to C:\ to install the mod outside of it.

Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #310794] Sun, 30 September 2012 23:04 Go to previous messageGo to next message
whatnameshouldi is currently offline whatnameshouldi

 
Messages:5
Registered:July 2012
I'm wondering, is there a way to tell if I'm playing with the new maps or the old ones? I'm trying to find some vehicle in Urban Chaos 1.13 but no luck so far (as far as I've read the jeep should be in A 10, but exactly where?).

Anyother place I should be looking at?

Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #310801] Mon, 01 October 2012 01:16 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Smigoz - try re-installing your original retail Jagged Alliance 2 outside of "Program Files (x86)" as a first step to re-installing UC-1.13 v3.65.1. I could not replicate the crash with the updated Stable release of v1.13.


whatnames - go into the Atremo UBT station and check the following:
- New Maps adds a cargo handling facility
- New Maps have the trains/tracks running from the upper left to lower right
Toggle Spoiler

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #310933] Fri, 05 October 2012 03:03 Go to previous messageGo to next message
Smigoz is currently offline Smigoz

 
Messages:18
Registered:March 2012
I'm not sure what i'm supposed to download when it comes to UC Data. I get a folder named ja2ucus with a bunch of UC_ENG_00(number) that can't be extracted and an exe that extracts a 1MB Data folder.

Just what am i supposed to do?

Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #310937] Fri, 05 October 2012 11:02 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
That is the original Urban Chaos default installer (and data files). Please follow these instructions to turn those into the Data-UC folder:

0) Download original Urban Chaos Installation files

1) Create an empty folder called C:\TARGET

2) Copy JA2.exe from your Jagged Alliance 2 v1.13 install into C:\TARGET

3) Run the Original Urban Chaos Installer
- the installation program will ask you to direct it to the path where Jagged Alliance 2 is installed, please direct it to C:\TARGET
- the installer will be satisfied you have pointed it to right path due to the JA2.exe you copied into C:\TARGET in Step 2 and proceed to unpack the original Urban Chaos

4) After the Original Urban Chaos Installer is finished, you will find a folder named DATA inside C:\TARGET
- rename this DATA folder DATA-UC

5) Copy DATA-UC to your Jagged Alliance 2 v1.13 root folder

For the rest of the installation please see: Standard Install Instructions in the Urban Chaos-1.13 Hybrid FAQ. The above is an elaboration on Part 3 of the Standard Install Instructions (if and only if you obtain your original Urban Chaos Data folder from the original Urban Chaos Installer).

[Updated on: Fri, 05 October 2012 11:09] by Moderator

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #312329] Thu, 22 November 2012 04:58 Go to previous messageGo to next message
Slax is currently offline Slax

 
Messages:1411
Registered:July 2006
Location: People riding polar bears...
Regarding balance...

I'm scared that large capacity .22 automatics are going to rule the board from beginning to end. Low usage costs, next to no recoil. Damage probably stacks real quick no matter what armor gets used, right? Spray and pray. Weapon overheating and degradation is probably going to play a nice role here, but still.

Accuracy really is a problem with NCTH these days, I feel. Problems no matter how you try to shape it. You make iron sights more viable and scopes instantly turn into flat to-hit bonus modifiers. This, as an example, renders sniper rifles completely goofy since max accuracy seems to be unreasonably capped while still allowing a great deal of accuracy even for unaimed shots.
Turn down iron sight viability and we're back to unreasonably bad gameplay, with or without scopes. Doesn't seem to be any sweet spot from what I can tell. So, why go high caliber if you won't be able to hit anything anyway? Might as well spray your pea-shooter until the barrel comes off.

Thoughts?

Report message to a moderator

Sergeant Major
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #312638] Thu, 29 November 2012 23:13 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
The iron sight system is counter-balanced by all scopes having the mirror image penalty.
Iron Sight = NCTH Cap Bonus
Scope = NCTH Cap Penalty = Zero NCTH Cap Modifier when the scope is attached.

I can drop the damage on any 22 weapon capable of automatic fire by another point or two. Additionally .22 LR lacks AP ammo.

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #312644] Fri, 30 November 2012 06:08 Go to previous messageGo to next message
knightofni is currently offline knightofni

 
Messages:96
Registered:August 2011
Fully agree on the 22 LR issue. A 22 LR SMG + a muzzle brake has such a low recoil (less than 2) that it becomes is a very good weapon. Even against armored opponents (spectra), you can spill so many bullets than one of them will get a headshot. I think the key here is to increase a little bit the recoil.

However high calibers are quite efficient. With tactical iron sights + precision AR-15 stock, you get very nice aiming cap modifiers which guarantees to hit your opponent at almost every shot (with a decent merc). For instance, the Ruger Mini 68 became an excellent weapon.

[Updated on: Fri, 30 November 2012 06:56] by Moderator

Report message to a moderator

Corporal 1st Class
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #312649] Fri, 30 November 2012 12:08 Go to previous messageGo to next message
Slax is currently offline Slax

 
Messages:1411
Registered:July 2006
Location: People riding polar bears...
Maybe balance it by disallowing muzzle brakes on such a low caliber. Seems like it wouldn't do much good in the real world but I really have no idea.
Well, I'd really like to see more strictness on the attachments overall (taking threaded barrels into account, that sort of stuff). And an all around boost on stock guns. Why would they get produced if you need aftermarket parts to even make them resemble a viable weapon?

Report message to a moderator

Sergeant Major
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #312655] Fri, 30 November 2012 22:03 Go to previous messageGo to next message
Hazapuza

 
Messages:262
Registered:February 2009
Location: Finland
From a realism standpoint, and the one model fits all foregrip and bipod aside, I'm not sure if there is much room for limiting available attachments, with all the rail systems and whatnot. Unless wil starts to delete some of that stuff, or introduces more "artificial" restrictions (not that there's anything wrong with that, if done correctly).

There is a strong reliance on attachments to get good performance out of weapons, that's true, but then again that's been pretty much the name of the game as long as 1.13 has existed.

Report message to a moderator

Master Sergeant
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #312662] Sat, 01 December 2012 08:25 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
New Common Attachment Point (NCAP) encourages trying to group attachments as much as possible - and separating Muzzle Brakes from the pistol suppressor NCAP would be a pain. It would be easier to increase the recoil, but how much can be justified for .22LR?

Ironically the above problem can justify a big reducion of damage from select fire .22LR - we'll all just agree that cycling the action eats a lot of energy from the round.

[Updated on: Sat, 01 December 2012 08:26] by Moderator

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314592] Tue, 22 January 2013 17:06 Go to previous messageGo to next message
Pariah is currently offline Pariah

 
Messages:77
Registered:June 2004
Location: Suckit City, OH

Greetings all and especially you wil473,

Two errors, didn't check on the 1st one because it was minor, but I did do a search for the 2nd one because it is a major one (warning my Search-Fu is weak but I did ask twice yesterday on the Bearpit channel on Quakenet but didn't see a response).

1st, background. I downloaded the latest UC 1.13 from Tais. Then I had issue because idjit me didn't realize I didn't have to unpack the 2nd folder from Tais, just have it in the same folder when I unzipped the 1st folder (that one stumped me for a few days, didn't help that for me Quakenet was down by an apparent hack).

But got on Quakenet and was set straight. So I unpacked the file and then moved them into a fresh JA2 directory (both under C:/Games and not Program Files X86).

Okay background done time for errors.

1st was after I got the game loaded and started I read the backgroun info because it has been like 5+ years since I last played UC. Error was on the Link from AIM to show the underground train schedule. Looked like two screens were over lapping each other (the 2nd screen looked to be the original screen) and neither screen was interactive. Not sure if it was supposed to be.

2nd error was a game breaker. Loaded six IMPs (the Xmen) and had them arrive in Danubia. However per the script once arrived the rebels attacked and it went into turnbased. But when I gave movement orders to my unit they all walked BACKWARDS. After getting the same result to all six mercs I saved the game and exit. Restarting got some progress the 1st 3 mercs I clicked on ran fine but then everyone went back to either walking backwards or if they were near one of the boxes they would move sideways instead of running.

Guys on Quakenet suggested Click+Alt and Alt+Tab. Alt+Tab just compressed to Desktop and Click+Alt made them run to a clicked location but once there they bent over looking for something.

So, how do I get my Mercs to walk/run forward?

Thanks,

Albert - Eastwoodaen

Report message to a moderator

Corporal
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314594] Tue, 22 January 2013 17:18 Go to previous messageGo to next message
Sam Hotte

 
Messages:1966
Registered:March 2009
Location: Middle of Germany
Usually the "mercs walk backwards" issue is due to the game not recognising that alt key has been released (E.g. because user alt+tabbed out of game). So usual cure is to press the alt key once in game and it's solved.

Your description makes me think that functionalty of CTRL and ALT are switched in your game because usually "searching ground and/or pick up item" is done by CTRL+click.

Report message to a moderator

Sergeant Major
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314640] Wed, 23 January 2013 17:44 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Eastwoodaen
1st was after I got the game loaded and started I read the backgroun info because it has been like 5+ years since I last played UC. Error was on the Link from AIM to show the underground train schedule. Looked like two screens were over lapping each other (the 2nd screen looked to be the original screen) and neither screen was interactive. Not sure if it was supposed to be.


v1.13 has not externalized the website stuff so the original text is integrated into the .exe and will always display (unless a custom .exe is compiled).

Eastwoodaen

2nd error was a game breaker. Loaded six IMPs (the Xmen) and had them arrive in Danubia. However per the script once arrived the rebels attacked and it went into turnbased. But when I gave movement orders to my unit they all walked BACKWARDS. After getting the same result to all six mercs I saved the game and exit. Restarting got some progress the 1st 3 mercs I clicked on ran fine but then everyone went back to either walking backwards or if they were near one of the boxes they would move sideways instead of running.

Guys on Quakenet suggested Click+Alt and Alt+Tab. Alt+Tab just compressed to Desktop and Click+Alt made them run to a clicked location but once there they bent over looking for something.

So, how do I get my Mercs to walk/run forward?


I just simply close and reopen the game to clear this issue when it happens to me (it is a v1.13 issue and not mod specific). However I have yet to try Sam's advice.

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314954] Wed, 30 January 2013 21:28 Go to previous messageGo to next message
gm0411 is currently offline gm0411

 
Messages:12
Registered:May 2008
Hey guys

Really excited for this mod but can't get it to work.

Using Urban Chaos-1.13 v3.65.1 20120421 the game loads but CTDs on the loading screen when I try and deploy at the airport.

Runtime Error
Assertion Failure [Line 2832 in file .\worlddef.cpp]

Then I uninstalled everything and tried it with Urban Chaos-1.13 v3.75 20120921 Full and it now CTDs on the Sirtech credit screen right at the start. (screenshot below)

http://tinypic.com/r/2vtw314/6

Any suggestions on next steps? i'm on win7 64-bit.

Cheers



Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314959] Wed, 30 January 2013 21:54 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Sticking with the last general release, v3.65.1, the usual questions:
1) into what folder did you install original Jagged Alliance 2?
2) what version of JA2 v1.13 are you using?

Last time I ran into a worlddef crash it was because I forgot to do some preparation work for an advance v1.13 graphic feature (which incidentally I'm not specifying as UC-1.13 v3.65.1 does not support it).

[Updated on: Wed, 30 January 2013 21:54] by Moderator

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314976] Thu, 31 January 2013 03:23 Go to previous messageGo to next message
gm0411 is currently offline gm0411

 
Messages:12
Registered:May 2008
Hiya, thanks for the response.

1)Folder is C:\Jagged Alliance 2 Gold

2)I've tried it with r4870 and also the version someone linked to earlier in this thread in response to a similar issue, file name is SCI_113_Stable_r1343_20111126_gdo

Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314978] Thu, 31 January 2013 05:06 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Probably best if you abandon your current install and do a clean install. Check that your JA2 Stable 1.13 Release (4870) works first before proceeding to install UC-1.13 v3.65.1 and importing in the original Urban Chaos data folder.

[Updated on: Thu, 31 January 2013 05:10] by Moderator

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #314987] Thu, 31 January 2013 15:00 Go to previous messageGo to next message
gm0411 is currently offline gm0411

 
Messages:12
Registered:May 2008
Yea 1.13 works fine. I'll talk you through what I do after that...

Copy JA.exe in to a dummy folder and install original US there. Rename data folder to Data-UC and copy it to my actual JA installation folder.

Extract UC-1.13 v3.65.1 to my actual JA installation folder.

Run using the INI Editor

Any thoughts?

Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #315035] Fri, 01 February 2013 03:22 Go to previous messageGo to next message
Wil473

 
Messages:2815
Registered:September 2004
Location: Canada
Dr_Horse

Copy JA.exe in to a dummy folder and install original US there. Rename data folder to Data-UC and copy it to my actual JA installation folder.

Extract UC-1.13 v3.65.1 to my actual JA installation folder.

Run using the INI Editor

Any thoughts?



Well those look like the steps after installing Stable v1.13. The problem is the errors you are running into may be the result of corrupted/missing files with either/or both original UC and UC-1.13 v3.65.1. On top of that, you've already mentioned messing around with later v1.13 releases.

Again, abandon your current install, you don't have to delete, just reinstall original Jagged Alliance 2 to a different folder for now. Then:
1) get v1.13 stable working, remember to add that patch for stable.
2) proceed with importing in original Urban Chaos Data, you may want to try another source. I believe Kaerar's SCI for Original Urban Chaos has it already unpacked and all you need to do is extract the DATA folder and rename it.
3) re-extract Urban Chaos-1.13 v3.65.1 (Full) 20120421, do not use any of the optional patches as I am suggesting you stick with Stable v1.13 rev.4870 (with only its bugfix patch).

Report message to a moderator

Lieutenant

Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #315051] Fri, 01 February 2013 17:09 Go to previous messageGo to next message
gm0411 is currently offline gm0411

 
Messages:12
Registered:May 2008
wil473

1) get v1.13 stable working, remember to add that patch for stable.


Sorry, by that do you mean there is an additional patch to download to make v1.13 stable? Could you link me pls?

Report message to a moderator

Private
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #315056] Fri, 01 February 2013 17:49 Go to previous messageGo to next message
Sam Hotte

 
Messages:1966
Registered:March 2009
Location: Middle of Germany
http://ja2v113.pbworks.com/w/page/4218334/Downloads
"Current official Update (Bugfix) Version (25 July, 2012) for Full Release Build: 4870"

Report message to a moderator

Sergeant Major
Re: UC-1.13 Discussions and Bug Reporting (2011/07/30 to 2011/--/--)[message #315070] Sat, 02 February 2013 03:28 Go to previous messageGo to previous message
gm0411 is currently offline gm0411

 
Messages:12
Registered:May 2008
Wahey, it works! Amazing, thank you!

Report message to a moderator

Private
Previous Topic: Urban Chaos-1.13 v3.7x ADCAP
Next Topic: Alrulco Folding Stock Discussion & Bug Reports - (2011/08/06 - 20--/--/--)
Goto Forum:
  


Current Time: Tue Jun 25 10:52:03 GMT+3 2024

Total time taken to generate the page: 0.05268 seconds