BP Logo
Home » PLAYER'S HQ 1.13 » v1.13 Solutions,Tips & Spoilers » Win 7 64: Screen does not refresh
Win 7 64: Screen does not refresh[message #323820] Fri, 09 August 2013 10:34 Go to next message
TheAnyKey

 
Messages:57
Registered:March 2010
Hi,

I have JA 2 Gold with 1.13 (4870) installed under L:/Jagged Alliance 2 Gold. I start it as admin and in Win XP SP 2 compatibility mode.

The game starts fine but then the screen does not refresh. The cursor leaves traces on the screen and when clicking buttons the new screens often don't show at all. I can't even get through the set up of a new game.

Any ideas?

Thanks

My system: AMD Phenom II X6 @3.3Ghz, 8Gb RAM, Gfx: AMD HD 5970
Re: Win 7 64: Screen does not refresh[message #323823] Fri, 09 August 2013 13:07 Go to previous messageGo to next message
wanne (aka RoWa21)

 
Messages:1973
Registered:October 2005
Location: Austria
disable all the fancy features from your graphic card. there are similar post here in the forum.


Re: Win 7 64: Screen does not refresh[message #323824] Fri, 09 August 2013 13:37 Go to previous messageGo to next message
TheAnyKey

 
Messages:57
Registered:March 2010
RoWa21
disable all the fancy features from your graphic card. there are similar post here in the forum.


In the Vision Engine Control Center under "Gaming" -> "3D Application Settings" I have chosen all the lowest settings. Still the issue persists unchanged.
Re: Win 7 64: Screen does not refresh[message #323830] Fri, 09 August 2013 15:19 Go to previous messageGo to next message
Sam Hotte

 
Messages:1988
Registered:March 2009
Location: Middle of Germany
Try without "Win XP SP2" compatibility (It's doing fine on win 7 64 bit without, also on Radeon, but older 4850 here).
Re: Win 7 64: Screen does not refresh[message #323831] Fri, 09 August 2013 16:09 Go to previous messageGo to next message
Slax

 
Messages:1430
Registered:July 2006
Location: People riding polar bears...
Update drivers, set all and any graphics stuff to defaults and rub some pennies together.

Re: Win 7 64: Screen does not refresh[message #323832] Fri, 09 August 2013 18:03 Go to previous messageGo to next message
TheAnyKey

 
Messages:57
Registered:March 2010
Graphics settings are at their lowest, compatibility mode is off.

Still it looks like this (left screen, I have a 28" 1929x1200 and a 19" 1280x1024, in extended display mode):

http://i43.tinypic.com/e9fa02.jpg

http://i40.tinypic.com/2sayqvr.jpg
Re: Win 7 64: Screen does not refresh[message #323839] Fri, 09 August 2013 21:01 Go to previous messageGo to next message
Sam Hotte

 
Messages:1988
Registered:March 2009
Location: Middle of Germany
Disable Extended Display (for testing) and run the game solely on the 19" Screen.
Re: Win 7 64: Screen does not refresh[message #323842] Fri, 09 August 2013 23:32 Go to previous messageGo to next message
TheAnyKey

 
Messages:57
Registered:March 2010
Sam_Hotte
Disable Extended Display (for testing) and run the game solely on the 19" Screen.


No luck, doesn't solve the issue.
Re: Win 7 64: Screen does not refresh[message #323848] Sat, 10 August 2013 10:21 Go to previous messageGo to next message
TheAnyKey

 
Messages:57
Registered:March 2010
Is it possible to play solely in software mode? Maybe it helps to disable the graphics acceleration?

I also tried turning 5 cores off, so it runs only on a single core but somehow in the Task Manager on right click -> set affinity I get the "Unable to access or set process affinity error".
Re: Win 7 64: Screen does not refresh[message #323855] Sat, 10 August 2013 18:32 Go to previous messageGo to next message
Sam Hotte

 
Messages:1988
Registered:March 2009
Location: Middle of Germany
TheAnyKey
Is it possible to play solely in software mode? Maybe it helps to disable the graphics acceleration?

Why don't you just give it a try. You can't lose anything, can you?
Re: Win 7 64: Screen does not refresh[message #323858] Sun, 11 August 2013 00:29 Go to previous messageGo to next message
wanne (aka RoWa21)

 
Messages:1973
Registered:October 2005
Location: Austria
Take a look at the following threads. They all deal with similar graphic problems:

http://www.ja-galaxy-forum.com/board/ubbthreads.php/ubb/showflat/Number/318670/Searchpage/1/Main/20951/Words/ati+graphic/Search/true/Re_graphical_glitch_with_4870_.html#Post318670
http://www.ja-galaxy-forum.com/board/ubbthreads.php/topics/300623/JA2_graphics_are_like_running_.html#Post300623
http://www.ja-galaxy-forum.com/board/ubbthreads.php/ubb/showflat/Number/201044/Searchpage/1/Main/14041/Words/catalyst/Search/true/Re_mouse_artifacts.html#Post201044
http://www.ja-galaxy-forum.com/board/ubbthreads.php/ubb/showflat/Number/275601/Searchpage/1/Main/18045/Words/catalyst/Search/true/Re_Jagged_Alliance_2_1_13_in_W.html#Post275601


Re: Win 7 64: Screen does not refresh[message #323899] Sun, 11 August 2013 22:56 Go to previous messageGo to next message
Uriens

 
Messages:341
Registered:July 2006
I had this issue as well and managed to solve it. Roman's third link actually points to right solution. The problem is in fact with cards that have more then one GPU on them. Mine is, for example, ATI Radeon HD 5970 which has 2 GPU-s. Some old games, including JA2, have issues with those cards and in order to play them you need to disable second GPU. Disabling AI in Catalyst setting does the trick.
However, the problem is how to disable it since the option doesn't exist in Catalyst drivers anymore.
I use a freeware program that manages profiles for that purpose.
Re: Win 7 64: Screen does not refresh[message #323950] Tue, 13 August 2013 20:26 Go to previous messageGo to next message
TheAnyKey

 
Messages:57
Registered:March 2010
Uriens
I had this issue as well and managed to solve it. Roman's third link actually points to right solution. The problem is in fact with cards that have more then one GPU on them. Mine is, for example, ATI Radeon HD 5970 which has 2 GPU-s. Some old games, including JA2, have issues with those cards and in order to play them you need to disable second GPU. Disabling AI in Catalyst setting does the trick.
However, the problem is how to disable it since the option doesn't exist in Catalyst drivers anymore.
I use a freeware program that manages profiles for that purpose.


Thanks, what's that programs name?

I've played JA2 1.3 on my laptop, also on Win 7 and on a second desktop, Win XP. No problems on either of those systems. So you must be right the problem must be my HD 5970.

Re: Win 7 64: Screen does not refresh[message #323951] Tue, 13 August 2013 20:42 Go to previous messageGo to next message
Uriens

 
Messages:341
Registered:July 2006
I use RadeonPro to do it. Supposedly you can do it manually too but I don't have knowhow myself. If you need instructions on how to set it up I'll try to do step by step. Btw, if you run into other older games that have strange behavior you may also try to disable the second gpu and see if it helps. I know that Space Empires V has white screen flicker if you don't turn off second gpu. Probably more games that have it, just didn't run into many.
Interestingly enough, DOSBox games seem to work fine with both gpu-s.
Re: Win 7 64: Screen does not refresh[message #323952] Tue, 13 August 2013 20:55 Go to previous messageGo to next message
TheAnyKey

 
Messages:57
Registered:March 2010
Uriens
I use RadeonPro to do it. Supposedly you can do it manually too but I don't have knowhow myself. If you need instructions on how to set it up I'll try to do step by step. Btw, if you run into other older games that have strange behavior you may also try to disable the second gpu and see if it helps. I know that Space Empires V has white screen flicker if you don't turn off second gpu. Probably more games that have it, just didn't run into many.
Interestingly enough, DOSBox games seem to work fine with both gpu-s.


RadeonPro doesn't start. I get an error message saying "RadeonPro starup failure. Error: RadeonPro Support Service communication error. Start RadeonPro Support Service and try again." RadeonProSupport gives me upon execution the error: "Windows service start failure. Cannot start service from command line or debugger. A Windows service must first be istalled (using installutil.exe)..." Installutil.exe isn't in the folder though, just InstallUtil.InstallLog.

Is there a dedicated x64 version or what else could be the problem?

[Updated on: Tue, 13 August 2013 22:41] by Moderator

Re: Win 7 64: Screen does not refresh[message #323954] Tue, 13 August 2013 23:27 Go to previous messageGo to next message
pheloncab

 
Messages:279
Registered:August 2004
Location: So. Cal. or texas
On my AMD card, I created a profile for JA2, in the gaming 3d application settings.
and the trick for the artifacts was turning off the morphological filtering.

Re: Win 7 64: Screen does not refresh[message #323958] Wed, 14 August 2013 00:52 Go to previous messageGo to next message
Uriens

 
Messages:341
Registered:July 2006
TheAnyKey

RadeonPro doesn't start. I get an error message saying "RadeonPro starup failure. Error: RadeonPro Support Service communication error. Start RadeonPro Support Service and try again." RadeonProSupport gives me upon execution the error: "Windows service start failure. Cannot start service from command line or debugger. A Windows service must first be istalled (using installutil.exe)..." Installutil.exe isn't in the folder though, just InstallUtil.InstallLog.

Is there a dedicated x64 version or what else could be the problem?


That's weird. Do you have Microsoft .NET Framework 3.5 or at least 2.0? It's listed as requirements. Btw. they actually recommend you use x64 system. I also use Win 7 64 bit, shouldn't be a problem there. Also Microsoft DirectX Runtime June 2010 or newer is recommended but you probably have that. Check it out just in case.

pheloncab
On my AMD card, I created a profile for JA2, in the gaming 3d application settings.
and the trick for the artifacts was turning off the morphological filtering.



Didn't work for me, and he has the same card. OFC, doesn't hurt to try.



Here is a thread in RadeonPro forums about that error.
You know, you can google such messages to find solutions. Wink

[Updated on: Wed, 14 August 2013 00:59] by Moderator

Re: Win 7 64: Screen does not refresh[message #323963] Wed, 14 August 2013 07:45 Go to previous messageGo to next message
TheAnyKey

 
Messages:57
Registered:March 2010
I just uninstalled the latest drivers and installed Catalyst 12.1. I am missing the catalyst control center but the card is recognized and seems to work, the resolution is fine and JA2 works so far without those graphics problems.

Thanks guys, I appreciate it a lot.
Re: Win 7 64: Screen does not refresh[message #323967] Wed, 14 August 2013 10:01 Go to previous message
wanne (aka RoWa21)

 
Messages:1973
Registered:October 2005
Location: Austria
TheAnyKey
I just uninstalled the latest drivers and installed Catalyst 12.1. I am missing the catalyst control center but the card is recognized and seems to work, the resolution is fine and JA2 works so far without those graphics problems.

Thanks guys, I appreciate it a lot.


Perfect. Good to hear that you can finally run the gane without troubles.


Previous Topic: TT Pistol Vest vs Silencer
Next Topic: Just trying to fit all the little pieces together. . .
Goto Forum:
  


Current Time: Thu Sep 23 20:07:49 EEST 2021

Total time taken to generate the page: 0.05262 seconds