BP Logo
Home » MODDING HQ 1.13 » v1.13 Bug Reports » Bugs: Unofficial releases (SCI's), unstable and DEV builds (Read the first post before posting!)
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363261 is a reply to message #363091] Mon, 17 May 2021 19:30 Go to previous messageGo to next message
barrind
Messages:3
Registered:April 2018
JA2 Unstable R9027 on G2589 downloaded from the Jenkins download site yesterday.

Whilst going through some of the AdditonalDealer_XX.xml files prior to modding one of them slightly I found that in the file "AdditionalDealer_43.xml there where two item indexes which appear to have been used twice. Indexes 26 and 41 are the ones which appear to be duped. I assume that in game the later one in each would overwrite the first and thus not actually present itself as a bug/crash, but I thought it would be worthwhile reporting this as it as I guess the overwritten item will not actually appear on the vendor as intended?

File: Jagged Alliance 2/Data-1.13/TableData/NPCInventory/AdditonalDealer_43_Inventory.xml

Duped line #1:

<INVENTORY>
<uiIndex>26</uiIndex>
<sItemIndex>1422</sItemIndex>
<ubOptimalNumber>6</ubOptimalNumber>
</INVENTORY>
<INVENTORY>
<uiIndex>26</uiIndex>
<sItemIndex>1456</sItemIndex>
<ubOptimalNumber>3</ubOptimalNumber>
</INVENTORY>

Duped Line #2:

<INVENTORY>
<uiIndex>41</uiIndex>
<sItemIndex>1709</sItemIndex>
<ubOptimalNumber>3</ubOptimalNumber>
</INVENTORY>
<INVENTORY>
<uiIndex>41</uiIndex>
<sItemIndex>1715</sItemIndex>
<ubOptimalNumber>1</ubOptimalNumber>
</INVENTORY>

This is probably a very minor issue but I thought I'd report it. Easy to fix I guess if someone can confirm these are not an intentional dupes?

[Updated on: Mon, 17 May 2021 19:30]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363282 is a reply to message #362767] Mon, 24 May 2021 18:29 Go to previous messageGo to next message
ShaDoOoW

 
Messages:52
Registered:April 2009
Location: Czech Republic
Brms08 wrote on Sat, 27 March 2021 03:50

Item duplication bug: Entire sector inventory sometimes keeps getting duplicated whenever I doubleclick on that sector to open its inventory. In other words, whenever I open the sector inventory, the game creates another copy of each item in that sector. Not sure why it happens but I've encountered this bug in three different playthroughs. Restarting the game seems to fix it.
cannot reproduce, need exact steps how to do it, perhaps with savegame with sector that you manage to do it - I tried doubleclicking on the inventory button when I right click thesector but it didn't work

Brms08 wrote on Sat, 27 March 2021 03:50

Getting hit by stray bullets from a battle taking place in a different sector: Not sure what triggers it but sometimes when you get into a fight in far away a sector, one of your mercs in a totally different sector, who's been repairing stuff or training, gets hit by stray bullets from a battle in a different sector which isn't even close. It's most likely the first merc you hired, in my case it was the IMP guy.
if you can get me a save where this happen after enemy shoots at least once per 20 loads I can fix this

Brms08 wrote on Sat, 27 March 2021 03:50

After taking care of the enemies in the first sector of Omerta, if you hire more mercs or IMPs without leaving the sector, neither the helicopter nor the mercenaries actually show up, even though the game adds them to squads and plays the landing dialogue. Not only that but the game keeps repeating their dialogues about the flight for the new mercs (IMPs) and doesn't play the dialogues for all the new mercs.
This seems to be fixed now, it was probably related to this: https://github.com/aimnas/ja2-1.13-source-mirror/commit/a38b3b414f6b729e9bd380b942bc807901dde408

Brms08 wrote on Wed, 07 April 2021 19:33
Build 8955

Not sure if this has anything to do with enabling XML squad names, but when you select a merc from another team on the tactical screen, the game displays an incorrect message about the team they are a member of, for instance, if you select a merc from team Alpha then the game says squad *Bravo* is active, if you select team Echo, then it says team *Foxtrott* is active and so on. I guess the active team number is miscalculated (whereas it should be one less) hence the incorrect name.
fixed
Brms08 wrote on Tue, 13 April 2021 01:52
If you talk to Waldo AFTER you brought Skyrider to the helicopter, Waldo still gives you the quest to find Skyrider and the map markers for the quest are also added to the map which are probably not possible to get rid of after that point.
fixed as well

[Updated on: Mon, 24 May 2021 20:15]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363283 is a reply to message #363091] Mon, 24 May 2021 18:35 Go to previous messageGo to next message
ShaDoOoW

 
Messages:52
Registered:April 2009
Location: Czech Republic
Anderson wrote on Sun, 02 May 2021 21:25
Hi,

I use JA2-Unstable-r8990-g2589 and Ja2_r8997.exe and I have DYNAMIC_OPINIONS = FALSE but still, there is information about improvement merc. opinions after shooting somebody. And I have Stephan and Meltdown and they don't comment on each other progress. Isn't there any problem with this?

Opinions in general works because Razor quit after 2 sectors walk with Flo. :-)

Thanks for the answer in advance.
Dynamic opinions can be turned off now. Not sure what you mean with Stephan and Meltdown though.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363294 is a reply to message #363283] Fri, 28 May 2021 17:25 Go to previous messageGo to next message
Uriens

 
Messages:338
Registered:July 2006
JA2 Unstable R9014

1) Bug with item manipulations - when combining items mercs start getting 'not enough AP' message after few successful combinings. Happens when sector inventory is open and no enemy is present. To reproduce, try combining a 5+ items with single merc (like in AIMNAS combining vests with woodland camo uniform). Happens regardless if current sector is loaded. Older versions (pre 9000) didnt have this bug. Not enough AP message persists if you load or exit/reenter game. The way to end it is to close sector inventory and unpause game even for a moment. I usually use CTRL + LMB to combine but i believe this happens if you combine them the 'long' way as well.
Note that message doesn't appear if you use CTRL+LMB method, it simply wont work - you see message if you try it the old way, moving item into another item and pressing just LMB.
Easiest way to reproduce this by trying to combine 10+ RDX crystals with C1 or TNT.

2) Inactive Deidranna forces - after a while Deidranna will suddenly stop reinforcing/replenishing garrisons and stop attacking lost sectors. I mean complete stop, not just some locations. Seems to happen around 20% progress mark, tested on both Expert and Insane difficulties. I'm currently playing with significantly modified AIMNAS (hoping to help Smeagol a bit) so i cant provide a save when this happened. I did test it on vanilla AIMNAS too on a pre 9000 build and had same thing happen.
In my current game it happened after i took entire Drassen + mine and repelled counter attack as it gave me a sudden jump in game progress (from 18~19 to 26).
Using NEW_AGGRESSIVE_AI = TRUE and AGGRESSIVE_STRATEGIC_AI = 2

3) Counter Attack forces overflow - I love how you can specify the amount of enemies in each of 4 enemy groups used in counterattack but if you use larger numbers like 64 enemies per group AND a patrol happens to be in the vicinity of the attack you will get overflow and only have few enemy soldiers show up for the attack. I suggest adding a hard cap of 255 soldiers attacking a single sector to avoid overflows. OFC if you get a counter attack with no patrols nearby, enemies show up properly. I have currently dropped the amount of enemies per group to <CounterAttackGroupSize>48</CounterAttackGroupSize> and i try to clear the area of patrols before triggering counterattack.

4) I also have a request - in these later builds i noticed a LOT of militia shuffling and moving when the sector is loaded and no enemies present. Most notable in sectors with 20+ militia. It slows down game a lot including time flow when unpausing game. I'd ask to reduce frequency of AI decisions when in uncontested sector (to like 1/5 of current frequency) and/or a way to unload current sector without moving all mercs away or loading a different one as unloading a sector is the only way at the moment to reduce a strain of CPU with current AI. AI is way better then original and doesn't have nearly as much problems with friendly fire as i remember it but its current resource load when in idle sector with lots of militia is definitely something that needs to be addressed.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363296 is a reply to message #363282] Sat, 29 May 2021 22:56 Go to previous messageGo to next message
Brms08

 
Messages:15
Registered:June 2008
ShaDoOoW wrote on Mon, 24 May 2021 18:29
Brms08 wrote on Sat, 27 March 2021 03:50

Item duplication bug: Entire sector inventory sometimes keeps getting duplicated whenever I doubleclick on that sector to open its inventory. In other words, whenever I open the sector inventory, the game creates another copy of each item in that sector. Not sure why it happens but I've encountered this bug in three different playthroughs. Restarting the game seems to fix it.
cannot reproduce, need exact steps how to do it, perhaps with savegame with sector that you manage to do it - I tried doubleclicking on the inventory button when I right click thesector but it didn't work
Unfortunately posting a save won't help you reproduce issue as it goes away when you restart the game and load the save. The issue only occurs in runtime. I have a suspicion that it might be related to enemy duplication bug I mentioned earlier where you convert a bunch of enemy soldiers before you start attacking the enemy in a sector, but I may be wrong.

[Updated on: Sat, 29 May 2021 22:56]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363303 is a reply to message #363294] Tue, 01 June 2021 15:39 Go to previous messageGo to next message
ShaDoOoW

 
Messages:52
Registered:April 2009
Location: Czech Republic
Uriens wrote on Fri, 28 May 2021 17:25
JA2 Unstable R9014

1) Bug with item manipulations - when combining items mercs start getting 'not enough AP' message after few successful combinings. Happens when sector inventory is open and no enemy is present. To reproduce, try combining a 5+ items with single merc (like in AIMNAS combining vests with woodland camo uniform). Happens regardless if current sector is loaded. Older versions (pre 9000) didnt have this bug. Not enough AP message persists if you load or exit/reenter game. The way to end it is to close sector inventory and unpause game even for a moment. I usually use CTRL + LMB to combine but i believe this happens if you combine them the 'long' way as well.
Note that message doesn't appear if you use CTRL+LMB method, it simply wont work - you see message if you try it the old way, moving item into another item and pressing just LMB.
Easiest way to reproduce this by trying to combine 10+ RDX crystals with C1 or TNT.
I cannot reproduce it with the latest svn revision (9058). Tried to combine 15 RDX with TNT and it worked without issues, since it takes around 30AP, the bug should be happening at 4th attempt already, but it didn't. Try download latest SCI, not sure how often is that automatic SCI from svn code generated but we are at 9058 now so your version is quite old.

[Updated on: Tue, 01 June 2021 19:30]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363315 is a reply to message #363303] Wed, 02 June 2021 20:04 Go to previous messageGo to next message
Uriens

 
Messages:338
Registered:July 2006
ShaDoOoW wrote on Tue, 01 June 2021 12:39
Uriens wrote on Fri, 28 May 2021 17:25
JA2 Unstable R9014

1) Bug with item manipulations - when combining items mercs start getting 'not enough AP' message after few successful combinings. Happens when sector inventory is open and no enemy is present. To reproduce, try combining a 5+ items with single merc (like in AIMNAS combining vests with woodland camo uniform). Happens regardless if current sector is loaded. Older versions (pre 9000) didnt have this bug. Not enough AP message persists if you load or exit/reenter game. The way to end it is to close sector inventory and unpause game even for a moment. I usually use CTRL + LMB to combine but i believe this happens if you combine them the 'long' way as well.
Note that message doesn't appear if you use CTRL+LMB method, it simply wont work - you see message if you try it the old way, moving item into another item and pressing just LMB.
Easiest way to reproduce this by trying to combine 10+ RDX crystals with C1 or TNT.
I cannot reproduce it with the latest svn revision (9058). Tried to combine 15 RDX with TNT and it worked without issues, since it takes around 30AP, the bug should be happening at 4th attempt already, but it didn't. Try download latest SCI, not sure how often is that automatic SCI from svn code generated but we are at 9058 now so your version is quite old.
Ok, gonna try it with latest SCI
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363325 is a reply to message #363315] Sat, 05 June 2021 19:11 Go to previous messageGo to next message
kazpex

 
Messages:5
Registered:June 2021
Hello,

I am new on this forum and I dont have knowledge about programing but I really like your version of this diamond between all games. I can be only beta tester or send donate if it is any possibility to support like this.

My little issue/question is when my merc has pistol (for example) and he does side step, he looks like he has rifle. Is it common thing or maybe can it be change in future?
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363326 is a reply to message #363325] Sat, 05 June 2021 20:33 Go to previous messageGo to next message
Seven.

 
Messages:2518
Registered:December 2012
Location: Russian Federation
kazpex wrote on Sat, 05 June 2021 21:11
My little issue/question is when my merc has pistol (for example) and he does side step, he looks like he has rifle. Is it common thing or maybe can it be change in future?
Cannot reproduce in r9061 with Igor and pistol, sidestepping shows pistol animation.
What version you are using? What bodytype (male, female, bigmale)?



7609+AI (r2136) | Experimental project | Modpack | Youtube | Trunk (r9087) | 1.13 Starter Docs | 1.13 How to get | Win10 fix | Discord


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363328 is a reply to message #363326] Sat, 05 June 2021 22:09 Go to previous messageGo to next message
kazpex

 
Messages:5
Registered:June 2021
It is body type male (merc Jimmy) and version 8796 (I got from this topic on this forum Depri's Builds and Packages - Get your combat supplies here!).

[Updated on: Sat, 05 June 2021 22:13]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363329 is a reply to message #363328] Sat, 05 June 2021 22:18 Go to previous messageGo to next message
Seven.

 
Messages:2518
Registered:December 2012
Location: Russian Federation
kazpex wrote on Sun, 06 June 2021 00:09
It is body type male (merc Jimmy) and version 8796 (I got from this topic on this forum Depri's Builds and Packages - Get your combat supplies here!).
This version is outdated, please use most recent SCI from this link:
https://jenkins.maeyanie.com/job/JA2%20SCI/



7609+AI (r2136) | Experimental project | Modpack | Youtube | Trunk (r9087) | 1.13 Starter Docs | 1.13 How to get | Win10 fix | Discord


Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363330 is a reply to message #363329] Sun, 06 June 2021 02:06 Go to previous messageGo to next message
kazpex

 
Messages:5
Registered:June 2021
Nice, thank you. Should I replace files or reinstall everything?

[Updated on: Sun, 06 June 2021 14:44]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363332 is a reply to message #362826] Sun, 06 June 2021 20:42 Go to previous messageGo to next message
ShaDoOoW

 
Messages:52
Registered:April 2009
Location: Czech Republic
Brms08 wrote on Fri, 09 April 2021 22:00
Build 8918 and 8955:

Major bug at IMP creation:

Some of the personality stats (friendly/threaten approach etc.) for the IMP character created after the first ten (i.e. the eleventh IMP and beyond) are always zero. You can check these stats on the laptop by using the "more stats" button on the "Personnel" section. The only way to create an 11th IMP (and further) that doesn't have this bug is to create them in the first 10 slot and then restart the game and import their dat file by using their names instead of the password "xep624" on IMP website.
This bug should be fixed now. SVN revision 9066. Not sure why these stats are lowered in omerta, if you can provide me savegame where this can be reproduced I can take a look at it.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363336 is a reply to message #363325] Mon, 07 June 2021 19:43 Go to previous messageGo to next message
ShaDoOoW

 
Messages:52
Registered:April 2009
Location: Czech Republic
kazpex wrote on Sat, 05 June 2021 19:11
Hello,

My little issue/question is when my merc has pistol (for example) and he does side step, he looks like he has rifle. Is it common thing or maybe can it be change in future?
I can confirm this. Also happening with nothing in hand or knife/melee weapon in hand. Looking into this right now, but it is possibly an animation problem not coding.

EDIT: ok confirmed. Ja2 currently has only one animation for sidestepping without being in ready position and that animation shows rifle in hand. If someone makes the new animations for sidestep with nothing in hand, pistol in hand, pistol in both hand and possibly knife in hand, this can be addressed, what about you and 3d modelling? happy

[Updated on: Mon, 07 June 2021 21:53]

Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363343 is a reply to message #363336] Wed, 09 June 2021 09:30 Go to previous messageGo to next message
kazpex

 
Messages:5
Registered:June 2021
I've never done this before but maybe it's not a big problem to switch from a rifle to a pistol. Is there any basic animation file?
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363345 is a reply to message #363303] Wed, 09 June 2021 13:53 Go to previous messageGo to next message
Uriens

 
Messages:338
Registered:July 2006
ShaDoOoW wrote on Tue, 01 June 2021 12:39
Uriens wrote on Fri, 28 May 2021 17:25
JA2 Unstable R9014

1) Bug with item manipulations - when combining items mercs start getting 'not enough AP' message after few successful combinings. Happens when sector inventory is open and no enemy is present. To reproduce, try combining a 5+ items with single merc (like in AIMNAS combining vests with woodland camo uniform). Happens regardless if current sector is loaded. Older versions (pre 9000) didnt have this bug. Not enough AP message persists if you load or exit/reenter game. The way to end it is to close sector inventory and unpause game even for a moment. I usually use CTRL + LMB to combine but i believe this happens if you combine them the 'long' way as well.
Note that message doesn't appear if you use CTRL+LMB method, it simply wont work - you see message if you try it the old way, moving item into another item and pressing just LMB.
Easiest way to reproduce this by trying to combine 10+ RDX crystals with C1 or TNT.
I cannot reproduce it with the latest svn revision (9058). Tried to combine 15 RDX with TNT and it worked without issues, since it takes around 30AP, the bug should be happening at 4th attempt already, but it didn't. Try download latest SCI, not sure how often is that automatic SCI from svn code generated but we are at 9058 now so your version is quite old.
Ok, made a new fresh install with 9059 SCI, no options or files changed at all.

Here is a video of the bug:



First thing to notice in the video is that i was using CTRL+LMB to merge items. After 5th merge it stopped working, wouldn't merge with shortcut anymore. When i used item description window to merge item, it worked. However, when i tried to merge a different items (Dynamite+RDX) i got the 'not enough action points' message. Apparently if you keep merging SAME item combo you can keep doing it as long as you dont use shortcut but after that any other item combo wont work. As mentioned before, unpausing the game and letting any amount of time pass (even 1 minute) will reset the "AP's" and you can do some more merging. Obviously, there should be no AP limits in sector inventory while there is no combat present.

Here is a save file used for testing.

https://drive.google.com/file/d/1so7sXmazO7XrrhwfrUm_OVIMKnQtNpRz/view?usp=sharing
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363349 is a reply to message #363345] Wed, 09 June 2021 23:14 Go to previous messageGo to next message
ShaDoOoW

 
Messages:52
Registered:April 2009
Location: Czech Republic
I see CTRL+LMB, I didn't know this and only did that manually via description box which worked correctly.

I just commited a fix for this, not sure when jenkins makes a new SCI with this in, but it is fixed now. This was a code unification with tactical/mapscreen which I didn't test (mainly because I didn't know CTRL+LMB merging is a thing). And the code in tactical was not having this issue because in realtime it seems that soldier APs are continously refreshed to max, which is not the case of mapscreen.

Eitherway, when I was at it, I found and fixed another issues related to this. Should be now bug free. Enjoy merging thumbs up
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363350 is a reply to message #363349] Thu, 10 June 2021 01:26 Go to previous messageGo to next message
Kitty

 
Messages:309
Registered:October 2017
Location: Germany
ShaDoOoW wrote on Wed, 09 June 2021 23:14
I just commited a fix for this, not sure when jenkins makes a new SCI with this in, but it is fixed now.
--

The Jenkins Server is an automated process. It updates once per day, if changes detected. For timezones with CET, that's arround midnight. The new SCI (r9069-g2592) was finished while writing this.

I also updated my own SCI to this just now.

Downloadlinks for both SCI at:

How to get: latest 1.13, 7609, feature-descriptions and more





How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363353 is a reply to message #363349] Thu, 10 June 2021 13:43 Go to previous messageGo to next message
Uriens

 
Messages:338
Registered:July 2006
ShaDoOoW wrote on Wed, 09 June 2021 20:14
I see CTRL+LMB, I didn't know this and only did that manually via description box which worked correctly.

I just commited a fix for this, not sure when jenkins makes a new SCI with this in, but it is fixed now. This was a code unification with tactical/mapscreen which I didn't test (mainly because I didn't know CTRL+LMB merging is a thing). And the code in tactical was not having this issue because in realtime it seems that soldier APs are continously refreshed to max, which is not the case of mapscreen.

Eitherway, when I was at it, I found and fixed another issues related to this. Should be now bug free. Enjoy merging thumbs up
Thx. thumbs up

For that second bug with Deidranna's army going inactive, i'll do some more testing. Gotta do several restarts anyway so may as well do some more probing. Right now i suspect its related with Arulco Special Division feature i have turned on, but still need to confirm it.
Re: Bugs: Unofficial releases (SCI's), unstable and DEV builds[message #363367 is a reply to message #363353] Mon, 14 June 2021 03:07 Go to previous message
Uriens

 
Messages:338
Registered:July 2006
Looks like Get Item merc assignment is not working in 2069 version. Items are simply not moved.

Edit: Seems to work now. Gonna keep testing to see what happened. First time this didn't work was in Omerta trying to move items from A9 to A10 sector. A10 was loaded. Second time this works is in the same sector after i took out patrol Deidranna sends to A9 and this time A10 was not loaded.

[Updated on: Mon, 14 June 2021 07:46]

Previous Topic: Bugs: 2014 Official 1.13 Release (7435) with 7609 Update
Goto Forum:
  


Current Time: Sat Jun 19 20:42:40 EEST 2021

Total time taken to generate the page: 0.03115 seconds