Home » PLAYER'S HQ 1.13 » JA2 Complete Mods & Sequels » Vengeance 1.13 Reloaded » Modding Vengeance: changing tileset generic 1
Modding Vengeance: changing tileset generic 1[message #364878] Thu, 15 September 2022 17:47 Go to next message
kata is currently offline kata
Messages:2
Registered:September 2022
Hi! I am really impressed by the Vengeance 1.13 Reloaded mod. So, I thought I'd use it as a basis to do some modding myself. As a starter, I looked into modifying some tilesets. For example, I wanted to switch dirtroad.sti against street2.sti in the generic 1 tileset.

In the Data-Maps-Tiles folder, I changed the respective entry in Ja2Set.dat.xml:

<file index="78">street2.sti</file>

I open the editor (default A9 sector), and switch the tileset to generic 1. The selection for road tiles correctly shows the street2 tiles. But when I place a road tile it still displays as a dirtroad tile. This also happens if I create a new map and place road tiles (dirtroad tiles appear).

I also tried changing the 78. entry of 00. GENERIC 1 in JA2SET.dat (under Data-Maps-Tiles/BinaryData) to street2.sti. No change, dirtroad tiles appear.

Then, I copied the STREET2.sti and STREET2.jsd from Data-Maps-Tiles/Tilesets/50 to Data-Maps-Tiles/Tilesets/0 and STREET2.sti from Data-Maps-Tiles/Tilesets/50/T to the Data-Maps-Tiles/Tilesets/0/T. Still no change, dirtroad tiles appear when placing a road tile.

Does anyone know what I am doing wrong here? not sure Btw, feel free to move this thread to the modding section, if this is not the right place to ask...

Report message to a moderator

Civilian
Re: Modding Vengeance: changing tileset generic 1[message #364880 is a reply to message #364878] Sat, 17 September 2022 16:53 Go to previous message
kata is currently offline kata
Messages:2
Registered:September 2022
Well, to answer my own question: The road tileset appears to be somewhat "special". File index 78 seems to govern the tileset that is shown in the interface of the editor. However, the tiles that are displayed after placing a road tile appear to be assembled from multiple tiles stored in file index 50 (default: roadtile.sti). In the editor, this tileset (roadtile.sti) is shown under banks & cliffs.

I tried swapping out other tilesets (e.g., debris) and this worked as expected. In particular, editing Ja2Set.dat.xml seems to do the trick without having to mess around with JA2SET.dat.

Report message to a moderator

Civilian
Previous Topic: To Hawkeye, Permission to RIP
Next Topic: Install question
Goto Forum:
  


Current Time: Wed May 22 11:37:57 GMT+3 2024

Total time taken to generate the page: 0.00666 seconds