Home » PLAYER'S HQ 1.13 » v1.13 Solutions,Tips & Spoilers » How to get: latest 1.13, 7609, feature-descriptions and more (Tired of searching? Here are the links and informations you need to start)
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364194 is a reply to message #361643] Mon, 17 January 2022 00:16 Go to previous messageGo to next message
Amgot is currently offline Amgot

 
Messages:12
Registered:April 2011
Hi all,

a couple of issues/questions related to the different install possibilities listed in the OP:

1. attempting to launch UC (w/ Kitty's 7609 SCI + Urban Chaos-1.13 v4.50 Full 20141222 + Data-UC) with the latest JA2+AI.exe (ja2_7609en+AI_r2349) gives me a runtime error (Assertion Failure [Line 329 in fileStrategic Movement Costs.cpp] Incorrect traversal data 'SOUTH' for sector row=8 column=9 in MovementCost.xml). I must have done something wrong in the install process but I can't find what I've done wrong exactly. Launching UC with the regular ja2.exe doesn't give me that runtime error.

2. how would I go about if I wanted to shift UC mercs stats back to their vanilla stats? I always hated those stat changes. Not a huge deal though, I can live with them.

3. how can I change Arulco Revisited music and background screens back to vanilla ones? Not a big fan of the new ones. Once again, not a huge deal, it's just cosmetic (and down to personal preferences ofc).

Report message to a moderator

Private
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364195 is a reply to message #364194] Mon, 17 January 2022 00:21 Go to previous messageGo to next message
Deleted.

 
Messages:2689
Registered:December 2012
Location: Russian Federation
1. This error needs to be fixed in XML. My 7609 modpack has UC version that should work with +AI, you can take needed file from there. Compare xml file with winmerge if needed.
2. Check Data-UC-113\TableData\MercProfiles.xml, it's all there, you should be able to copy+paste stats for needed mercs from stock 1.13, just don't change anything mod related like sector placement for NPCs.
3. Go to Data-AR\Music, rename or delete files, the game will use default music from Data\Music.slf
Backgrounds are in Data-AR\Interface\OptionsScreenBackground*.sti and Data-AR\Loadscreens

[Updated on: Mon, 17 January 2022 00:40]




Left this community.

Report message to a moderator

Lieutenant

Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364196 is a reply to message #364195] Mon, 17 January 2022 00:43 Go to previous messageGo to next message
Amgot is currently offline Amgot

 
Messages:12
Registered:April 2011
Thanks for the (very) quick reply!

1. I need to extract the Mods\Data-UC113.7z from your modpack and then get the XML, is that correct? But which XML are you talking about (or are there several I need to check)?

2. thanks.

3. done, thanks! Also got rid of the new main menu background.

[Updated on: Mon, 17 January 2022 00:44]

Report message to a moderator

Private
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364197 is a reply to message #364196] Mon, 17 January 2022 00:53 Go to previous messageGo to next message
Deleted.

 
Messages:2689
Registered:December 2012
Location: Russian Federation
Yes, take the file from 7z archive and use it to fix xml bug in your installation.
Since your error mentions MovementCost.xml, this is the file I would try to fix.

[Updated on: Mon, 17 January 2022 00:54]




Left this community.

Report message to a moderator

Lieutenant

Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364262 is a reply to message #364197] Sun, 30 January 2022 04:22 Go to previous messageGo to next message
Vercingetorix is currently offline Vercingetorix

 
Messages:7
Registered:February 2018
I downloaded the Modpack from Seven.
1)How can I play UC113? I just can select vfs.config.UC. Is this the right one? When yes, how can I change the ini. settings like Train Elite Militia or Max IMP Skill points?
2)And another question. What is the Level Progression? I think I read someting about the weapons progression. Can I change there something special or is it just to use with no aditional possible changes fot its setting?
3)Are there any recommendations regarding the drop all settings or the supported NCTH setting(LP, UC?) for each mod?
And sorry for the not perfect english.....

[Updated on: Sun, 30 January 2022 04:38]

Report message to a moderator

Private
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364263 is a reply to message #364262] Sun, 30 January 2022 10:43 Go to previous messageGo to next message
Deleted.

 
Messages:2689
Registered:December 2012
Location: Russian Federation
1. Ja2.ini says:
; JA2 1.13 Urban Chaos
VFS_CONFIG_INI = vfs_config.UC.ini
You can change ini settings in data-1.13, mod folder and Data-User (which has highest priority).
2. What is the Level Progression? Do you have a screenshot or something.
3. Drop all will quickly give you better weapons and equipment but later you will have thousands of items in sectors and it kind of ruins game item availability balance since you have too much and too early. I would not recommend it unless you clearly know what you do.
The mods are expected to play with default NCTH setting, there are also some useful tweaks in CTHConstants.ini in Data-User.



Left this community.

Report message to a moderator

Lieutenant

Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364264 is a reply to message #364263] Sun, 30 January 2022 18:15 Go to previous messageGo to next message
Vercingetorix is currently offline Vercingetorix

 
Messages:7
Registered:February 2018
1)I already played some mods an know some things like how to change settings with the ini editor. But when I select the vfs.config.UC in the ini editor there is no ini file where i can change settings for UC. I already changed for each ini file from the ini editor the settings for IMP_MAX_ATTRIBUTE but I can´t set the IMP Point in the game above the standard 85 for UC. So I don´t know how to change these setting for UC. For other mods it works.

2) For example the mod AR+LP which is to chose from the ini editor.

I don´t know how to post screenshot. I can´t just copy it in. If you could tell me how to I could post some screeenshots.

[Updated on: Sun, 30 January 2022 20:50]

Report message to a moderator

Private
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364348 is a reply to message #364264] Fri, 18 February 2022 22:26 Go to previous messageGo to next message
bole is currently offline bole

 
Messages:57
Registered:November 2002
To be honest, I have no idea what that Jenkins server thing is.

All I know is that, when I click on the link (I think it is link, at least) fort he latest stable build (message, I assume, marked as #784) I get the link to download some file that has word unstable in it.
It has been some 10 years since I had installed the new version of 1.13,but I think I'll stick with that 7zip place.

Report message to a moderator

Corporal
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364354 is a reply to message #364348] Sat, 19 February 2022 09:53 Go to previous messageGo to next message
Asdow is currently offline Asdow

 
Messages:100
Registered:August 2010
It's just an automated setup that bundles newest gameDir and .exe revisions together so it doesn't have to be done manually. The latest stable build in there means the latest build that didn't give errors upon building, it doesn't mean the old "stable" JA2 build. You'll usually want to download the latest successful artifact from there, unless you're after a specific revision.

The "unstable" on the filename does refer to the development trunk of 1.13, and yeah it's a bit unfortunate how easily those two can be mixed up.

[Updated on: Sat, 19 February 2022 09:57]

Report message to a moderator

Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364498 is a reply to message #364354] Sun, 20 March 2022 15:35 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
Changed my update frequency for my SCI, instead of "once per month" it's now "every now and then".

In case some needs xp-compatible exe and mine are not around, use the Jenkins SCI and replace the exe with the exe provided by seven (see a few post above).



How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364527 is a reply to message #364498] Sun, 27 March 2022 17:17 Go to previous messageGo to next message
wickedinsane is currently offline wickedinsane

 
Messages:32
Registered:March 2010
Location: GERMANY
Is the +AI mod/functionality included in the latest Jenkins/Kitty SCI builds? If not, is it compatible and safe to use with the latest builds?
If so, where would I get the latest files for this?

Report message to a moderator

Private 1st Class
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364530 is a reply to message #364527] Sun, 27 March 2022 22:39 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
wickedinsane wrote on Sun, 27 March 2022 17:17
Is the +AI mod/functionality included in the latest Jenkins/Kitty SCI builds? If not, is it compatible and safe to use with the latest builds?
If so, where would I get the latest files for this?

Take a look at the very first post of this "How-to...", under "Getting 7609+AI" you'll find the link "Experimental Project 7". This will lead you to descriptions by author and downloadlink for the exe.

You'll need the 7609-version of 1.13 and replace the exe coming with 7609 with the improved one.

Ok, since your location says germany, I'll try to explain in german as well:

Neh, geht nicht mit den neuseten Versionen zusammen. +AI ist für die 7609-version von 1.13 gedacht. Ganz am Anfang von dem "How-to..." finden sich ein paar links und Beschreibungen dazu. Unter "Getting 7609+AI" ist ein link zu Beschreibungen vom Author (Experimental Project 7), da ist auch ein downloadlink für die neueste +AI-exe.

Was man braucht ist also erstmal die 7609-version von 1.13, downloadlinks dazu auch ganz am Anfang. Die exe da drin muss man mit der +AI-exe ersetzen.

Um das ganze Potential auszuschöpfen, würde ich aber empfehlen den 7609-modpack von seven runterzuladen, der enthält zusätzlich ein paar feine goodies in den Ordnern (extra sounds, etc)und das ist einfach der bequemste Weg alle mods die es für 7609 gibt auszuprobieren.
Und man ahnt es,auch dazu gibts die downloadlinks am Anfang, dritter Post. Die +AI-exe wird ständig verbessert, also immer mal nachschauen, ob seven (der author) eine aktuellere parat hat (der link unter Experimental Project 7).



How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364537 is a reply to message #364530] Wed, 30 March 2022 00:03 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
I put down one downloadsource (Kittyland). It's obsolete, because if you need XP-compabilty and UB and MapEditor, the polish forum provides SCI exactly for that already (link at first post). UB and MapEditor can also be compiled by anyone following the Guide (link in my signature). XP-compabilty can also be reached when replacing exe coming with Jenkins SCI (link in first post) with the one seven usually provides on his google-drive (see link in his signature).


EDIT: scrap the part about using exe from seven. since he has left this community and put down his google drive, that's no longer a thing. It might be possible that it's still available at russian forum (A.I.M. - see links further up), but you have to look it up yourself if wanted. The polish forum should be xp-compatible (at least that how i understand the posts there). In case that's no longer true, try to post a request here, I'll try to compile one if I have time (keep in mind that I don't check in daily, so this may take some time).

[Updated on: Mon, 30 May 2022 00:43]




How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364636 is a reply to message #364537] Tue, 10 May 2022 08:36 Go to previous messageGo to next message
Hazapuza

 
Messages:263
Registered:February 2009
Location: Finland
Nice job with the guide, Kitty. It's great.

It seems that the English versions of Seven's 7609+AI and modpacks are no longer available, though. Probably worth mentioning in the guide itself.

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364653 is a reply to message #364636] Sat, 21 May 2022 14:25 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
Hazapuza wrote on Tue, 10 May 2022 08:36
... It seems that the English versions of Seven's 7609+AI and modpacks are no longer available, though. Probably worth mentioning in the guide itself.
Updated guide. Didn't add direct links cause those are probably prone to change anyway.



How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364669 is a reply to message #364653] Sun, 29 May 2022 14:40 Go to previous messageGo to next message
Lynx2005 is currently offline Lynx2005

 
Messages:31
Registered:February 2021
Hello Kitty,

Quote:

"I put down one downloadsource (Kittyland) ... XP-compabilty can also be reached when replacing exe coming with Jenkins SCI (link in first post) with the one seven usually provides on his google-drive..."
The .exe gamedir 9370 provided from polish forum isn't XP-compatible.

Only (as I know) the .exe assembled by seven and sadly yours from kittyland was.

(german) "Hier beißt sich die Katze selbst in den Schwanz:"

My browser compatible to XP (firefox) can't download from google-drive: It is blocked there as not "up to date"...

Best regards
Lynx2005


Edit: Content, bad english - grammar, but now isn't better ... not sure

[Updated on: Sun, 29 May 2022 14:58]

Report message to a moderator

Private 1st Class
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364676 is a reply to message #364669] Sun, 29 May 2022 18:18 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
I just tried to compile it for XP but it gave me a bunch of errors. I reported it and hope that some of the coders can solve the issue.

Last statement about this i found on polish forum is from starchris and he said they aim to compile for older platforms. I assume they might have run into simular problems.

As for sevens google-drive, he put it down permanent and left all non-russian communities. some of his stuff apparently can be found on russian forum, but this probably is only for his 7609+AI. as far as I can tell, he doesn't provide the exe for standard 1.13 anymore.

so, sadly I'm not able to provide anything until some of the coders picks up on the problem. usually those gyus are fast, but I'm not sure if it can be solved at all, sorry.


P.S. I'm from Hessen, so I'm used to see grammar more as a guideline than a rule happy



How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364681 is a reply to message #364669] Mon, 30 May 2022 00:33 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
Lynx2005 wrote on Sun, 29 May 2022 14:40
Hello Kitty,...
JA2_r9388 (for g2650)

Thanks to rftr it's already fixed.

I uploaded just the exe. You'll need to download the latest 1.13 from Jenkins (first link in this "How-to-get...") and use the exe from here instead the one coming with Jenkins.

Keep in mind that exe should match the GameDir it was meant for, in this case g2650.



How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #364685 is a reply to message #364681] Tue, 31 May 2022 01:25 Go to previous messageGo to next message
Lynx2005 is currently offline Lynx2005

 
Messages:31
Registered:February 2021
Hello Kitty,
big thank you for your fast reply and to rftr for the .exe! thumbs up





edit: content

[Updated on: Tue, 31 May 2022 01:31]

Report message to a moderator

Private 1st Class
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365094 is a reply to message #364685] Sun, 01 January 2023 15:49 Go to previous messageGo to next message
Lynx2005 is currently offline Lynx2005

 
Messages:31
Registered:February 2021
Happy new year everybody!

Hello Kitty,

I've downloaded your newest V1.13 from Kittyland as it say xp-compatible (Using XP!). (Ugly Name of the new Version by the way...) suprised

Exe-Start direkt (doubleclick on exe-icon), as starting with ini-Editor results in the windowsmessage:

Der Prozedureneinsprungpunkt "CompareStringEx" wurde in der DDL "Kernel32.dll" nicht gefunden!

in english:
Processstartingpoint? (don't know how exactly translate this specialist term) "CompareStringEx" not found in DLL "Kernel32.dll"!

Report message to a moderator

Private 1st Class
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365103 is a reply to message #365094] Tue, 10 January 2023 23:23 Go to previous messageGo to next message
staninus is currently offline staninus
Messages:1
Registered:January 2023
Location: Czech Republic
Hi folks,

I've got the same issue with executables as Lynx2005. Using XP OS cause showing of described error message.

I was searching around this and maybe found what cause the issue probably.
Here on stackOverflow.com is discussion about the problem:
https://stackoverflow.com/questions/14349793/c-program-written-in-vs2012-works-w-win7-8-2008r2-2012-but-not-2003-xp-32bi t

Do we need to compile JA2 ourselves and use the trick from above link? That's the question..

[Updated on: Wed, 11 January 2023 00:43] by Moderator

Report message to a moderator

Civilian
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365105 is a reply to message #365094] Wed, 11 January 2023 06:13 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
Lynx2005 wrote on Sun, 01 January 2023 15:49
Happy new year everybody!

Hello Kitty,

I've downloaded your newest V1.13 from Kittyland as it say xp-compatible (Using XP!). (Ugly Name of the new Version by the way...) suprised

Exe-Start direkt (doubleclick on exe-icon), as starting with ini-Editor results in the windowsmessage:

Der Prozedureneinsprungpunkt "CompareStringEx" wurde in der DDL "Kernel32.dll" nicht gefunden!

in english:
Processstartingpoint? (don't know how exactly translate this specialist term) "CompareStringEx" not found in DLL "Kernel32.dll"!
Hm, not good, grr. I used VS19 with VS17 platform toolset for xp (VS19 doesn't have one on it's own, afaik). Got no warnings during compiling and it's running at my win10 (I've no more xp installed atm).
Tried to compile again with VS13 (and VS platform toolset for xp), which worked in the past.
But that gave me a bunch of errors, looks like the vcxproj and sln files for VS13 miss something.
I'm gonna do some research and see if someone can help me solving this on discord.
Not sure if they do it anymore, but you could try download from the polish forum (english version, no worries) https://jagged-alliance.pl/plik589/. At least in the past they also tried to achieve xp-compabilty.
I'll post again if we found a solution for this.

[Updated on: Wed, 11 January 2023 06:14]




How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365106 is a reply to message #365105] Wed, 11 January 2023 06:21 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
There is very promissing work to create automated releases on gitHub (workflow with cmake).

We would get something like the Jenkins did in the past. A new release whenever a change is made, automated.

Once that is done, I'm gonna update the links and give a short description on how to grab it.






How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365120 is a reply to message #365106] Sat, 21 January 2023 15:28 Go to previous messageGo to next message
Inveris is currently offline Inveris

 
Messages:31
Registered:September 2020
Where can I ask why there is no more french version of newest version from this automated process on github? Previously it always was.
https://github.com/1dot13/source/releases/tag/latest

Report message to a moderator

Private 1st Class
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365121 is a reply to message #365120] Sat, 21 January 2023 19:14 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
Inveris wrote on Sat, 21 January 2023 15:28
Where can I ask why there is no more french version of newest version from this automated process on github? Previously it always was.
https://github.com/1dot13/source/releases/tag/latest

Either at Bear's Pit Discord

or open up a new issue at gitHub: 1dot13 gitHub issues





How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365125 is a reply to message #365120] Sat, 21 January 2023 21:13 Go to previous messageGo to next message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
Inveris wrote on Sat, 21 January 2023 15:28
Where can I ask why there is no more french version of newest version from this automated process on github? Previously it always was.
https://github.com/1dot13/source/releases/tag/latest
Voilà, brought it to attention and the coding crew fixed it. French now included, please report if you find any issues with it

https://i.imgur.com/wNqSStu.png

[Updated on: Sat, 21 January 2023 22:09]




How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365134 is a reply to message #365125] Tue, 24 January 2023 20:35 Go to previous messageGo to next message
yarco is currently offline yarco

 
Messages:37
Registered:October 2013
Is it possible to add "what's new" to these releases?

Report message to a moderator

Private 1st Class
Re: How to get: latest 1.13, 7609, feature-descriptions and more[message #365135 is a reply to message #365134] Wed, 25 January 2023 03:24 Go to previous message
Kitty

 
Messages:358
Registered:October 2017
Location: Germany
yarco wrote on Tue, 24 January 2023 20:35
Is it possible to add "what's new" to these releases?
there is changelog at releases page and for more details also the commit history

imo, if it's a new feature, important addition, etc. it should also be posted on forum by the author to allow players/modders to inform themselves about it
and promote the new addition to get feedback on it

and that is exactly what happens most the time

new stuff is mostly under v1.13 Idea Incubation Lab

and/or at v1.13 Features How-Tos & Discussions

most of the older stuff is at Flugente's Magika Workshop


at the first page of this thread there is also a toggle for "Kinda Changelog" with some information

I'm about to overhaul the page to reflect the move to gitHub, but plan to do some short info like that regulary again (not for every release)


[Updated on: Wed, 25 January 2023 03:28]




How to get: latest 1.13, 7609 and more | 7609 SCI (eng) | Compiling+SVN

I need more details. (Didi Hallervorden)

Report message to a moderator

Master Sergeant
Previous Topic: New User Guide
Goto Forum:
  


Current Time: Sun Jan 29 08:47:55 EET 2023

Total time taken to generate the page: 0.02160 seconds