BP Logo
Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #340329 is a reply to message #340328] Tue, 31 March 2015 04:52 Go to previous messageGo to next message
Buggler

 
Messages:209
Registered:November 2009
smeagol wrote on Mon, 30 March 2015 21:13
Driving out of a map in tactical with a vehicle causes an unhandled exception, crashing the game (exe 7667 using bigmaps and ice-cream truck).

Happens in multiple sectors and seems to be 100% reproducible.


Does the crash happens when the mouse cursor is supposed to change to the tactical transverse icon at the map borders for the selected vehicle?

Are you using Depri's exe?
If so, the better coders could then have a look. It used to be an isolated incident occurring only for VS2008 release build, not affecting VS2005/VS2010.



No savegame (just before e bug occurs), no cure.

'Not everything that counts can b counted, n not everything that can b counted counts' - Albert Einstein
I may answer/reply in my old public posts & prefer PM over e former [FUDforum's PM suxx]
Re: BUGZILLA report all bugs here![message #340338 is a reply to message #340329] Tue, 31 March 2015 11:24 Go to previous messageGo to next message
smeagol

 
Messages:2730
Registered:June 2008
Location: Bremen, Germany
Yes, as far as I can tell, the crash happens when the cursor changes. Not 100% sure on that, though (it's hard to tell, when the actual crash happens, but yes, it may be related to that).

Always using Depri exe's.


Re: BUGZILLA report all bugs here![message #340358 is a reply to message #340338] Wed, 01 April 2015 21:43 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Hi, There seems to be serious bug in build 7783. To make sure I did clean installation of JA2, copied over 7783 from SCI and when I start a new game on insane level I eventually get Assertion Failure [Line 2887 in file Strategic Movement.cpp].

To reproduce:
1) start a new game on INSANE (other levels are fine, at least at the beginning).
2) Pick any merc, go to Omerta, kill enemies using cheat.
3) On strategic screen, you should now be only able to move 5 minutes ahead and then get stuck. Sometimes timer goes a bit further, but extremely slow.
4) Leave the game to first screen and start a new one. Pick any difficulty, assertion failure will occur.

Since the problem persists even on clean installation, I guess it's not caused by me and I just got lucky when because I started two games which run just fine, units move and attack (on insane level).
Btw, after save and reload you can move timer another 5 minutes ahead, but assertion failure will happen eventually anyway.

Re: BUGZILLA report all bugs here![message #340359 is a reply to message #340358] Wed, 01 April 2015 22:07 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
I just fixed a bug near that region a few minutes ago in r7805. It might be worth testing whether that fixes the issue.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340360 is a reply to message #340359] Wed, 01 April 2015 23:13 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Oh the miracle of building own exe...Thanks, problem seems to be solved!
Re: BUGZILLA report all bugs here![message #340415 is a reply to message #340360] Sat, 04 April 2015 14:57 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
There seems to be another one, or perhaps the same. Whenever I cancel movement orders, I get Assertion Failuere in same file: Line 2935 in file Strategic Movement.cpp

Saved game + ja2_options.ini
http://ulozto.cz/xCLMbkpc/7783cancelmomevementae-zip

Let me know if I can be of any further help.

Edit: Everything works fine right up to the moment there is a battle with reinforcements. After that, any movement order cancellation results in error. Tested on insane,
Build 7805

[Updated on: Sat, 04 April 2015 15:29]

Re: BUGZILLA report all bugs here![message #340425 is a reply to message #340415] Sat, 04 April 2015 23:38 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
Yoiks. Sorry, my fault. Fixed in r7809.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340433 is a reply to message #340425] Sun, 05 April 2015 14:47 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Thanks for fix, seems to be ok now.

Here is 7809 build, if anyone needed.
http://ulozto.cz/xGV7XcKp/ja2-en-7809-zip
Re: BUGZILLA report all bugs here![message #340463 is a reply to message #340433] Mon, 06 April 2015 16:55 Go to previous messageGo to next message
math3ws

 
Messages:19
Registered:March 2013
Location: Czech Republic
I found this bug while playing AFS, but IMHO it is an issue with the exe itself, so I'm posting it here.

The problem is with various dual-mode sights and variable magnification scopes. Sometimes (not always, but quite often), changing the magnification/mode results in unhandled exception and a subsequent CTD. This seems to happen especially if the gun with the scope has other attachments. I've noticed this happening in strategic and in tactical turnbased only, but it's possible that I was just un/lucky and this can happen in tactical non-turnbased aswell.

I could reproduce the bug in exe 7679 (the exe recommended for current version of AFS), and on a relatively new exe (about 3 weeks old revision, unfortunately I can't remember the exact revision number, but to my knowledge it was 7786)

steps to reproduce:
  1. Install AFS
  2. Edit IMP loadout (I added Wilson Combat Recon Rifle, Suppressor, RIS foregrip, RIS Lam/Tac Light, Match trigger and most importantly Dual Mode Sight)
  3. Start a new game, create IMP (use the new gear selection method and give your IMP all the stuff added in previous step), go to Omerta.
  4. Attach all the stuff to your gun, if it wasn't done automatically.
  5. Try changing scope mode several times while in turnbased or in strategic. This should do the trick.
Re: BUGZILLA report all bugs here![message #340491 is a reply to message #340463] Wed, 08 April 2015 00:55 Go to previous messageGo to next message
M16AMachinegun

 
Messages:304
Registered:September 2013
@ Chaos:

I can confirm this, theres at least one sight, for example, Dual Mode Sight (goes from 4x to 1.5x and back), which crash the game when attempting to transform the scope to a different mode
Re: BUGZILLA report all bugs here![message #340496 is a reply to message #340463] Wed, 08 April 2015 13:17 Go to previous messageGo to next message
Cardinal

 
Messages:45
Registered:September 2014
Chaos wrote


I could reproduce the bug in exe 7679 (the exe recommended for current version of AFS), and on a relatively new exe (about 3 weeks old revision, unfortunately I can't remember the exact revision number, but to my knowledge it was 7786)



M16AMachinegun wrote
I can confirm this, theres at least one sight, for example, Dual Mode Sight (goes from 4x to 1.5x and back), which crash the game when attempting to transform the scope to a different mode


Do you build your own exe? It used to happen back when I used VS2008.
Re: BUGZILLA report all bugs here![message #340499 is a reply to message #340496] Wed, 08 April 2015 16:16 Go to previous messageGo to next message
ratpaz

 
Messages:137
Registered:April 2015
Location: Italy
Few issues i found so far playing with r7809 on gamedir 2232:
- If i get an attack with tanks and i play the battle or do autoresolve with the active sector selected, after the battle the tanks will get bugged, they stay there as "ghost" tanks (can be displayed like there are vehicles on the sector)
then if i attempt to do a repair on that sector or try to get on these vehicles the game will crash to desktop.
Also during the attack if i play the battle sometime the tanks will not show up, the battle is declared won but the tank stay on the sector nowhere to be found, i can compress time, do repairs etc... but can't train militia, if i leave the sector it count as withdrew from the battle, the tank/s will eventually move from the sector after few hours.

- Kobra and reflex sight don't seems to work properly, the AP reduction is displayed on the item information, but it isn't applied when mounted to a weapon (playing with NCTH disabled)

- I don't know if this is a bug or a feature, but some scopes don't let me switch them when i press .(dot) key, 2x scopes seems to works always with all the weapons, but 4x, 7x e 10x don't works. The only weapons so far that will let me change scope mode even mounting a 4x or 7x scope is a Steyr AUG-A3, not sure if there are other weapons.

- This is not a bug, but deseases seems to occour too frequently, i mean playing on insane difficulty make the game way harder, mercenaries get 1-2 infections/day and i can't efford to hire a doctor to every city since i need all the manpower to replace dead militia, but maybe it is cause the sectors get so many corpes, i counted on a sector more than 150 dead bodies (i usually play most of the biggest battles, only do autoresolve on easy battles). Also healing deseases is too easy and fast (usually take 1-2 hours) but become much harder if the desease is ignored for only 1 day or so, even a doctor with 90+ medical can't handle.

- Crows are considered innocents by mercs and this worsens relationships since it happen frequently to kill them especially when using artillery strike.

[Updated on: Thu, 09 April 2015 15:42]

Re: BUGZILLA report all bugs here![message #340500 is a reply to message #340499] Wed, 08 April 2015 19:03 Go to previous messageGo to next message
silversurfer

 
Messages:2800
Registered:May 2009
ratpaz wrote on Wed, 08 April 2015 15:16

- Kobra and reflex sight don't seems to work properly, the AP reduction is displayed on the item information, but it isn't applied when mounted to a weapon (playing with NCTH disabled)

They only give a bonus when the corresponding scope mode is selected. You won't get the bonus from a reflex sight while looking through a 4x scope for example. This is working as intended.

ratpaz wrote on Wed, 08 April 2015 15:16

- I don't know if this is a bug or a feature, but some scopes don't let me switch them when i press .(dot) key, 2x scopes seems to works always with all the weapons, but 4x, 7x e 10x don't works. The only weapons so far that will let me change scope mode even mounting a 4x or 7x scope is a Steyr AUG-A3, not sure if there are other weapons.

Most scopes block iron sights so the only scope mode left is the scope itself or hip fire while standing (there is no hip fire while crouched or prone). This is also working as intended.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #340501 is a reply to message #340500] Wed, 08 April 2015 22:56 Go to previous messageGo to next message
ratpaz

 
Messages:137
Registered:April 2015
Location: Italy
Awesome!
Just catched the trick
you guys are making this game more realistic day by day
Re: BUGZILLA report all bugs here![message #340502 is a reply to message #340501] Wed, 08 April 2015 23:49 Go to previous messageGo to next message
math3ws

 
Messages:19
Registered:March 2013
Location: Czech Republic
Cardinal wrote on Wed, 08 April 2015 12:17
Chaos wrote


I could reproduce the bug in exe 7679 (the exe recommended for current version of AFS), and on a relatively new exe (about 3 weeks old revision, unfortunately I can't remember the exact revision number, but to my knowledge it was 7786)



M16AMachinegun wrote
I can confirm this, theres at least one sight, for example, Dual Mode Sight (goes from 4x to 1.5x and back), which crash the game when attempting to transform the scope to a different mode


Do you build your own exe? It used to happen back when I used VS2008.


I do build my own exe, but I'm using VS2013. While I don't see how could that fix a bug like this, I did try to use Depri's exe to be sure. I can still replicate the issue with exe 7679 and 7783.

[Updated on: Wed, 08 April 2015 23:50]

Re: BUGZILLA report all bugs here![message #340503 is a reply to message #340502] Thu, 09 April 2015 01:28 Go to previous messageGo to next message
Cardinal

 
Messages:45
Registered:September 2014
Chaos wrote on Wed, 08 April 2015 22:49

I do build my own exe, but I'm using VS2013. While I don't see how could that fix a bug like this, I did try to use Depri's exe to be sure. I can still replicate the issue with exe 7679 and 7783.


I guess I spoke out of turn then, sorry.
I used to get the exact same crash using a VS2008 exe because I couldn't get it to compile in VS2010. I've since re-installed VS2010 and it works fine now.
Re: BUGZILLA report all bugs here![message #340506 is a reply to message #340503] Thu, 09 April 2015 09:50 Go to previous messageGo to next message
math3ws

 
Messages:19
Registered:March 2013
Location: Czech Republic
Cardinal wrote on Thu, 09 April 2015 00:28
I guess I spoke out of turn then, sorry.
I used to get the exact same crash using a VS2008 exe because I couldn't get it to compile in VS2010. I've since re-installed VS2010 and it works fine now.


No, if anything I'm glad someone tried to help me. Unfortunately it didn't help. But thank you anyway.
Re: BUGZILLA report all bugs here![message #340507 is a reply to message #340499] Thu, 09 April 2015 20:17 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
ratpaz wrote on Wed, 08 April 2015 15:16
Few issues i found so far playing with r7809 on gamedir 2232:
- This is not a bug, but deseases seems to occour too frequently, i mean playing on insane difficulty make the game way harder, mercenaries get 1-2 infections/day and i can't efford to hire a doctor to every city since i need all the manpower to replace dead militia, but maybe it is cause the sectors get so many corpes, i counted on a sector more than 150 dead bodies (i usually play most of the biggest battles, only do autoresolve on easy battles). Also healing deseases is too easy and fast (usually take 1-2 hours) but become much harder if the desease is ignored for only 1 day or so, even a doctor with 90+ medical can't handle.


I also play insane difficulty and don't have this kind of problem. You should only get diseased if you mess with corpse, right? And only those not so fresh ones. I collect clothes from bodies a lot and haven't been diseased in this game so far. Did you perhaps went through swamp sector? If you do that with 10 mercs then the chance of leaving with two dissased mercs is quite high. If you even stayed for a few hours, than any big team without drugs is doomed. BTW, that makes western tropical SAM extremely hard to defend.

Or may be you are playing with food system on and have diseases reinfecting you from used food?

As for ease of healing - I think it's Flugente's intention for it to be easy when handled soon. As you say yourself, it gets tough enough when unattended...
Re: BUGZILLA report all bugs here![message #340508 is a reply to message #340507] Fri, 10 April 2015 00:06 Go to previous messageGo to next message
ratpaz

 
Messages:137
Registered:April 2015
Location: Italy
Well it was at beginning of the game, i headed to San Mona, made some quests there, then Chitzena and the sam site near by,
after that i headed toward Drassen and liberated it, food system was disabled.
So yes i went through few swamp sector, but also stationated on sectors filled with rotten bodies, but that is something usual playing this game, especially on insane, you can't leave a city you liberetad just to avoid to get diseases, you have to train militia as fast as possible, maybe magic Flugente should implement a bury bodies feature cheeky
i disabled deseases when i wasn't able to handle the problem anymore, oh and maybe i used a little earlier version, i think r7783 on gamedir 2226.
Anyway on my opinion deseases should be a rare event even on most dangerous environments, if i go to a swamp should be not that possible i get a disease, also i don't get a desease today and another tomorrow few hour after i was healed from the first one, or get 2-3 deseases at the same time.
I know it is possible to change desease probabilities changing variables on desease.xml, i tried reducing deseases by more than 500% but don't seems to had sort any noticable effect on my case.

[Updated on: Fri, 10 April 2015 00:08]

Re: BUGZILLA report all bugs here![message #340509 is a reply to message #340508] Fri, 10 April 2015 01:00 Go to previous messageGo to next message
edmortimer

 
Messages:1489
Registered:January 2015
Location: Home Free
Interesting reading regarding disease in wartime operations:

Toggle Spoiler


see: http://www.history.army.mil/books/Vietnam/MedSpt/chpt2.htm

Re: BUGZILLA report all bugs here![message #340522 is a reply to message #340509] Sat, 11 April 2015 19:13 Go to previous messageGo to next message
navaroe

 
Messages:79
Registered:August 2012
Well, 10 days into my insane game and I have 2 admissions due to battle injury and like 14 due diseases. I'll probably try to balance things more towards your link happy Especially mortality troubles me - I have Ira, Fox and MD working in Drassen hospital and still they are losing the battle against typhus and cholera. For large teams in insane games this awesome idea of diseases needs to be rebalanced, I think. Or perhaps make medicaments accessible bit sooner through BR?

I'll post results and XML in feature's thread some day soon.

[Updated on: Sat, 11 April 2015 19:14]

Re: BUGZILLA report all bugs here![message #340523 is a reply to message #340522] Sat, 11 April 2015 19:31 Go to previous messageGo to next message
edmortimer

 
Messages:1489
Registered:January 2015
Location: Home Free
Making more medical supplies available earlier and easier to come by is a realistic option. Adjusting Gearkits of the medics to have these items at the start is also realistic. It is, after all, the role of medics to prepare for these types of circumstances, and to be knowledgeable about them before arriving. Medics would know that disease is a primary problem they will encounter. As well, considering we don't have a medical version of an online store it makes sense to have Bobby Ray's sell all medical equipment at the start. Just my opinion as a medic.

Re: BUGZILLA report all bugs here![message #340561 is a reply to message #340523] Wed, 15 April 2015 19:18 Go to previous messageGo to next message
smeagol

 
Messages:2730
Registered:June 2008
Location: Bremen, Germany
No had evidence yet, but from little testing it seems, that rocks used as distractions are not functional atm.

Also it basically makes next to no difference if you are stealthy and running behind the back of an enemy or not, you seem to make no noise, whatsoever anyways.


Re: BUGZILLA report all bugs here![message #340577 is a reply to message #340561] Fri, 17 April 2015 19:24 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
I've noticed a few more bugs:
  • on certain conditions, entering a sector if a merc is a passenger of a vehicle in that sector causes CTD.
  • enemy artillery explosions are falsely attributed to the very first merc recruited, leading to other mercs complaining about 'friendly fire'
  • other minor stuff I've since forgotten
While I have the fixes, I am currently unable to commit them. Due to ... non-standard electrical conditions my router is fried, leaving me without internet (I'm posting this from somewhere else). I'll commit once I'm back online. This is just a reminder, so nobody feels to research these 2 bugs as well.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340601 is a reply to message #340328] Sun, 19 April 2015 12:48 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
smeagol wrote on Mon, 30 March 2015 21:13
Driving out of a map in tactical with a vehicle causes an unhandled exception, crashing the game (exe 7667 using bigmaps and ice-cream truck).

Happens in multiple sectors and seems to be 100% reproducible.
Fixed in r7817.
Also:
  • r7818: Fix: enemy artillery shells were wrongly attributed to have been fired from the first merc you hired, leading to lots of complaints about friendly fire.
  • r7819: Fix: crash when entering a sector if currently selected merc is in the helicopter
  • r7822: Fix: during strategic AI evaluation, player strength should be taken into account. However, due to very bad programming/deletion of code (not sure which one, probably both) not only is player strength not calculated sometimes, the variable isn't even initialized. Which can lead, to say, the AI assuming that the player has 54k mercs defending a sector, at which points it decides 'Nope, not going there'.
    We now at least initialize the thing to 0, so the AI can properly attack.
  • r7823: Technically not a fix, but it sure feels like one: As you might know, the AI cyclically evaluates the strategic situation and sends out garrison/patrol replacements. It creates a list of all sectors viable to be reinforced, then picks one of them (somewhat) randomly. However, if it then decides that it cannot send forces there (because, say, the sector has over 54k defenders), it does not send forces - it stops for this cycle.
    I've changed this so that in this case, it simply tries to send forces to the next sector on the list, until it is successful. This seems to be in line with what the AI should originally do. The combination of these 2 bugs (r7822 && r7823) could lead to the strategic AI being severely dumbed down, sending out teams at a much lower rate then was originally intended.

[Updated on: Sun, 19 April 2015 13:04]




I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340602 is a reply to message #340499] Sun, 19 April 2015 13:11 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
ratpaz wrote on Wed, 08 April 2015 13:16
...
- Crows are considered innocents by mercs and this worsens relationships since it happen frequently to kill them especially when using artillery strike.
Fixed in r7824.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340607 is a reply to message #340602] Sun, 19 April 2015 17:58 Go to previous messageGo to next message
smeagol

 
Messages:2730
Registered:June 2008
Location: Bremen, Germany
Unloading vehicles in sector inventory with shift+e makes the items disappear, while shift+w works fine.


Re: BUGZILLA report all bugs here![message #340617 is a reply to message #340433] Mon, 20 April 2015 02:23 Go to previous messageGo to next message
ExxonValdez

 
Messages:30
Registered:October 2014
Location: Poland, Wrocław
navaroe wrote on Sun, 05 April 2015 13:47
Thanks for fix, seems to be ok now.
Here is 7809 build, if anyone needed.
http://ulozto.cz/xGV7XcKp/ja2-en-7809-zip

Thx. By the way - 7809 build contain all previous bugfixes ?
Re: BUGZILLA report all bugs here![message #340619 is a reply to message #340617] Mon, 20 April 2015 10:17 Go to previous messageGo to next message
silversurfer

 
Messages:2800
Registered:May 2009
Yes, newer versions have all previous bugfixes.



Wildfire Maps Mod 6.07 on SVN: https://ja2svn.mooo.com/source/ja2/branches/Wanne/JA2%201.13%20Wildfire%206.06%20-%20Maps%20MOD

Re: BUGZILLA report all bugs here![message #340625 is a reply to message #340619] Mon, 20 April 2015 21:49 Go to previous messageGo to next message
smeagol

 
Messages:2730
Registered:June 2008
Location: Bremen, Germany
Instead of placing concertina wire, mercs will start complaining about the terrible condition, once it reaches low percentages, even though concertina wire is using the multiple placement per item option.


Re: BUGZILLA report all bugs here![message #340645 is a reply to message #340625] Tue, 21 April 2015 19:05 Go to previous messageGo to next message
ratpaz

 
Messages:137
Registered:April 2015
Location: Italy
2 more bugs r7809 gamedir 2232

- A tank spawned inside a house in Balime L11, not sure if it is a feature big grin but it sure look wrong.

- Assertion Failure (Line 3090 in file Stategic Movement.cpp) while entering on hammer for the first time 24 hours after i have bought it from Dave.


[Updated on: Tue, 21 April 2015 19:06]

Re: BUGZILLA report all bugs here![message #340680 is a reply to message #340625] Wed, 22 April 2015 21:46 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
smeagol wrote on Mon, 20 April 2015 18:49
Instead of placing concertina wire, mercs will start complaining about the terrible condition, once it reaches low percentages, even though concertina wire is using the multiple placement per item option.
Fixed in r7829.

This also fixes the bug that launchers happily launch whatever is attached to them via attachment points. If someone wants to define what a launcher can launch, use Items/Launchables.xml.



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340821 is a reply to message #340680] Fri, 01 May 2015 10:22 Go to previous messageGo to next message
ExxonValdez

 
Messages:30
Registered:October 2014
Location: Poland, Wrocław
Hello. I've started my JA2 test-gameplay on the newest release v7816 downloaded from https://onedrive.live.com/?cid=013a6926eac52083&id=13A6926EAC52083!583 .
I found blackscreen error occur in evry games after many days (I have tried new game and result was the same). After load savegame just press "next turn" and BS will appear.

savegame:
http://speedy.sh/F4sH2/SaveGame09.sav

[Updated on: Fri, 01 May 2015 10:23]

Re: BUGZILLA report all bugs here![message #340825 is a reply to message #340821] Fri, 01 May 2015 14:41 Go to previous messageGo to next message
smeagol

 
Messages:2730
Registered:June 2008
Location: Bremen, Germany
Placing movement orders for vehicle squads in the worldmap overview doesn't work properly if using two vehicles.

If you are moving two non-vehicle squads you issue movement orders to different sectors and both squads will move properly. However, the same doesn't apply to two squads in vehicles. Only the first squad will move and the second squad will remain in the sector, so you have to issue the movement orders to vehicle squads seperately, even if they have the same destination.


Re: BUGZILLA report all bugs here![message #340901 is a reply to message #340825] Wed, 06 May 2015 11:11 Go to previous messageGo to next message
smeagol

 
Messages:2730
Registered:June 2008
Location: Bremen, Germany
Switching taclights on/off while attached to a gun (without batteries) crashes the game.

Switching magnification via transformation of certain scopes sometimes crashes the game, sometimes it doesn`t. Hard to replicate, happens during tacctical view in AIMNAS while using a 7x re3dfield scope which can be transformed to 2x or 4x magnification. My guess is that it is either caused by the changed field of view or some amount of AP cost. Of course I might be totally wrong with this...

Using 7X35 exe (probably 8 or 9, whatever most recent release is... currently not at my gamedir PC).


Re: BUGZILLA report all bugs here![message #340942 is a reply to message #340901] Sun, 10 May 2015 15:10 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
Hmm. This can also happen in stock 1.13. Seems to only happen if attached to a gun. For some reason, sometimes a pointer is corrupted, resulting in random behaviour.

Edit: Fixed in r7855. However... the attachment code in general is so messed up I have a hard time determining whether the code is buggy, intended to be this obscure, or the result of some merging accident.

[Updated on: Sun, 10 May 2015 16:09]




I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340966 is a reply to message #340942] Tue, 12 May 2015 19:45 Go to previous messageGo to next message
ExxonValdez

 
Messages:30
Registered:October 2014
Location: Poland, Wrocław
Flugente, http://thepit.ja-galaxy-forum.com/index.php?t=msg&th=12303&goto=340821&#msg_340821 any news ?
Re: BUGZILLA report all bugs here![message #340971 is a reply to message #340966] Wed, 13 May 2015 11:30 Go to previous messageGo to next message
Uriens

 
Messages:338
Registered:July 2006
Using SCI 7835. I'm getting weapons with 100% condition to jam quite frequently. Not sure if that is related to those pointers because the way those jams happen are quite peculiar. Namely, I have like 6 or so same guns in the squad but only one of them will start jamming at 100% or close to 100% condition. Other times (other battle or maybe reload) another gun will start doing that while the previous one will no longer jam.

I'm also getting an error which causes game to crash shortly after: "schedule callback: illegal soldier ID of 0.". It's displayed in the message box in the bottom left corner, not like those assertion fail messages. I don't know to which feature that is connected so I'm reporting it here.

Edit: And just as I reported it, I got 2 guns to start jamming at max condition. Apparently, whatever the bug is, it doesn't have to be one item. Also, the jams are quite frequent, like gun condition is way below 50% so it makes it almost unusable. Never had that happen in the previous SCI so whatever was changed in between 7835 and the one before is likely the cause of it.

[Updated on: Wed, 13 May 2015 12:49]

Re: BUGZILLA report all bugs here![message #340972 is a reply to message #340971] Wed, 13 May 2015 13:08 Go to previous messageGo to next message
Flugente

 
Messages:3526
Registered:April 2009
Location: Germany
@ExxonValdez: will check once I have time, likely earliest the next weekend.

@Uriens: I assume you are using stock 1.13 on this one... Is overheating or dirt active? Any special things you did, like item transformationss?



I know now that it could never work between us, as much as we wanted to, it could never be! Not because you're a rabbit, but because you're black.

If you want, you can donate to me. This will not affect how and what I code, and I will not code specific features in return. I will be thankful though.


Re: BUGZILLA report all bugs here![message #340975 is a reply to message #340972] Wed, 13 May 2015 17:01 Go to previous messageGo to previous message
Uriens

 
Messages:338
Registered:July 2006
Nope, dirt and overheating are off. I always have them off, no other changes except for some usual changes I always do to ini file. No modifications to the other files.

Btw. in previous playthrough of UC mod with one version older SCI I had some problems when there was a vehicle present in the sector that was loaded. Problems like AI turn going into endless loop. No matter what I would do it wouldn't pass first AI turn. However, when I would move vehicle away from sector and then tried the same battle again - game would work normally. However, since this was both UC in question and I did use some shift+arrow rearranging of mercs (IIRC that used to mess up indexes while ago) I wasn't really sure what caused it so I didn't report it. That "schedule callback: illegal soldier ID of 0." error is something I saw first time since I play but, in the sector that was currently loaded, there was a vehicle present. It's possible it's related but not sure. Unloading sector and then reloading fixed that error problem and I wasn't able to reproduce it yet.

As far as the jams are concerned, it happens all the time. I'll look into it more closely, see if I manage to find a pattern and what causes it. Odd thing is that it currently only happens on one type of gun but currently I hardly have any other guns.

Edit: Ignore jam part of the report, I may have made a mistake in ja2_options.ini file. I'll check it out of it still happens but so far just ignore.
The "schedule callback: illegal soldier ID of 0." error is still valid though and I'll try to reproduce it.

[Updated on: Wed, 13 May 2015 18:11]

Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Tue Jun 15 06:27:38 EEST 2021

Total time taken to generate the page: 0.05215 seconds