BP Logo
Home » MODDING HQ 1.13 » v1.13 Bug Reports » BUGZILLA report all bugs here!
Re: BUGZILLA report all bugs here![message #309565] Mon, 27 August 2012 22:28 Go to previous messageGo to next message
JamTheDane

 
Messages:9
Registered:August 2012
I talked to JMich on another board, and he told me to go bug report here Smile

I been playing JA2 1.13 for a few days now, and have run into a really irritating bug.
I run the newest version, 4870, with the latest hotfix, no extra mods or changes.

I have tried to make 3 new games now, and I get his by this every time, after cleaning up the start area. Just after clearing the area, I will either get random people dropped from group (had a full group, or a group with 2 out of 5 mercs in it), but the game will crash with a " is not in a valid group. (pSoldier->ubGroupID is 0.", whenever I move the mouse cursor to one of the edges of the map. If i look at the island map, they are all in group 1.
When I get hit by it, it is 100% repeatable.
When affected by this, if I go in the map mode, and try to MOVE my squad, by clicking on the "Dest" field (to easily select all mercs), the game will also crash, but with no error message.

A workaround is to go out in map mode, and reassign all mercs to group 2, this will put them all in a group again, and stop the bug.

I have seen this bug in start area, in airport area of Drassen, and in the south part of Drassen.

Here are screenshots of the error itself, the action view with group, so you can see the full group exist, and one of the tactical view:

http://i.imgur.com/1K09u.jpg
http://i.imgur.com/Ote1e.jpg
http://i.imgur.com/BUsIb.jpg

If you want it, I took a copy of this savegame.
Re: BUGZILLA report all bugs here![message #309763] Sun, 02 September 2012 23:01 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
@Slax: Regarding the error of mercs getting the mount bonus on the roof even though they shouldn't: fixed in r5546.


Re: BUGZILLA report all bugs here![message #310045] Wed, 12 September 2012 19:00 Go to previous messageGo to next message
removed_one
Messages:4
Registered:April 2010
Hi. I recently just started playing again, but now I'm having problems with opening the XML and ini editors. I keep getting a message saying "A device attached to the system is not functioning." Never had that problem before, so I was wondering if anybody knows a fix.
Re: BUGZILLA report all bugs here![message #310496] Sat, 22 September 2012 06:21 Go to previous messageGo to next message
tim110011

 
Messages:12
Registered:August 2012
This is a request not a bug:
Update 3rd-party libraries ?
           SVN      NEW
7z(lzma) : 4.65     9.20
utfcpp   : 2.2.2    2.3.2
libpng   : 1.2.35   1.2.50
zlib     : 1.2.3    1.2.7
Re: BUGZILLA report all bugs here![message #310525] Sat, 22 September 2012 23:21 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3698
Registered:July 2009
Why? What's the benefit and how much is this potentially going to break?


Re: BUGZILLA report all bugs here![message #310527] Sun, 23 September 2012 06:12 Go to previous messageGo to next message
tim110011

 
Messages:12
Registered:August 2012
There are vulnerability warnings on libpng home page, zlib 1.2.3 also released 7 years ago.
My exe bulid (svn5579) with new libraries now works fine.
Re: BUGZILLA report all bugs here![message #310951] Fri, 05 October 2012 19:12 Go to previous messageGo to next message
rtm
Messages:1
Registered:October 2012
I've found a neat bug in 5412 with wildfire maps.

Mike shows up in Tixa, gets shot IIRC without even a chance to speak.
After I clear out the dungeon there, I go on to clear out the cache at J12.

Can't find last enemy. So, I google the forums, then try the alt-E cheat.

Works. Turns out there's an invisible, dying Mike in the upper right corner of the map. Even though his corpse definitely was at Tixa..

Truly invisible, his only presence is indicated by the square being impossible to move onto. It doesn't show the cross, just the merc won't go there.
Re: BUGZILLA report all bugs here![message #311713] Fri, 02 November 2012 13:14 Go to previous messageGo to next message
Parkan

 
Messages:436
Registered:April 2010
Location: Russia,Sevastopol

Ja2+SCi 5645.
If i play with tooltips level 4(debug).The enemy and militia units have wrong description about their traits.For example:Enemy has trait-Athletics-but this is not athletics-it is Bodybuilding.

Plus.If player play with IMP mercs where they have more than 3 traits(major\minor)(for example i play with 4 major\4 minor) the description tooltip in laptop if i want to see More trait-is wrong too.(For example:I created merc with Machinegunner,hand to hand, Deputy,Bodybuilding,Athletics,Night Ops,Ambidex.The laptop menu show-Machinegunner,hand to hand,Deputy,Night ops,More.If i look to More i saw only Athletics,teaching.The teaching i not chose when IMp merc was created.

Such bugs was in previus versions like in 5555 exe.
Cheked with stock 1.13 mod,and with AFS and UC mod separatle.This bugs occur.

http://i.imgur.com/xyj5Y.jpg

[Updated on: Fri, 02 November 2012 13:21] by Moderator

Re: BUGZILLA report all bugs here![message #311717] Fri, 02 November 2012 18:15 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
@Parkan: I have an idea how your error occured... I'll see to it in the next week or so.


Re: BUGZILLA report all bugs here![message #311728] Sat, 03 November 2012 00:31 Go to previous messageGo to next message
Parkan

 
Messages:436
Registered:April 2010
Location: Russia,Sevastopol

Such errors appear after adding new Covert operation skill.before that skill there was no such bug.
Re: BUGZILLA report all bugs here![message #311730] Sat, 03 November 2012 00:51 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
I know, because I had to change a lot concerning trait numbering and displays Smile


Re: BUGZILLA report all bugs here![message #311753] Sat, 03 November 2012 18:30 Go to previous messageGo to next message
Uriens

 
Messages:340
Registered:July 2006
Just to add to this specific bug. Actual skills you chose work properly, it's just 'more' tooltip that that displays wrong skill (-1 index i think). For example if 13 is athletics then it will show as melee skill in 'more' tooltip because melee has 12 index. However, if you test it in game, you can see that merc really gets movement reduction from athletics as he should.
Re: BUGZILLA report all bugs here![message #311754] Sat, 03 November 2012 18:45 Go to previous messageGo to next message
Parkan

 
Messages:436
Registered:April 2010
Location: Russia,Sevastopol

Not just "more" tooltip work not properly,the tooltip level 4(debug)on enemy work not properly too.
Re: BUGZILLA report all bugs here![message #311755] Sat, 03 November 2012 18:51 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3698
Registered:July 2009
And you see this ... how?


Re: BUGZILLA report all bugs here![message #311756] Sat, 03 November 2012 18:59 Go to previous messageGo to next message
Parkan

 
Messages:436
Registered:April 2010
Location: Russia,Sevastopol

in ja2_option.ini tooltip level detail-4.If i understand you correctly.=)
Re: BUGZILLA report all bugs here![message #311757] Sat, 03 November 2012 19:07 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3698
Registered:July 2009
No, I know what you're talking about. But how do you know those tooltips are wrong? It's not like traits are a weapon the enemy drops afterwards that differs from the TT.


Re: BUGZILLA report all bugs here![message #311758] Sat, 03 November 2012 19:26 Go to previous messageGo to next message
Parkan

 
Messages:436
Registered:April 2010
Location: Russia,Sevastopol

I made some testing.Increased damage reduction of bodybuilding to 90% and looked to result.enemy who have athletics and gain a little damage-have wrong trait.
Re: BUGZILLA report all bugs here![message #311760] Sat, 03 November 2012 20:31 Go to previous messageGo to next message
Uriens

 
Messages:340
Registered:July 2006
I seem to have a problem setting up manual militia restrictions. Right click should cycle through sector colors allowing me to set up restrictions in the 'r' screen. However, right click does nothing and i can't find a way to change restrictions on map. I only get green (patrol) and grey (no entry) sectors.
Setting RESTRICT_ROAMING, ALLOW_MILITIA_MOVEMENT_THROUGH_EXPLORED_SECTORS and ALLOW_DYNAMIC_RESTRICTED_ROAMING to various combinations in .ini file didn't help much. Did something change with manual restrictions lately or is this a bug?
Can't seem to find anything about it using search function.

Btw, I'm using latest SVN version with 5656 exe version.

[Updated on: Sat, 03 November 2012 20:34] by Moderator

Re: BUGZILLA report all bugs here![message #311791] Sun, 04 November 2012 22:13 Go to previous messageGo to next message
Uriens

 
Messages:340
Registered:July 2006
After more testing I think I can confirm this as a bug.
At the moment you can't manually set restrictions for mobile militia. In 'r' screen you should be able to right click on the explored sector to cycle it's color (green/yellow/red). However, this function does not work.

I have RESTRICT_ROAMING and ALLOW_MILITIA_MOVEMENT_THROUGH_EXPLORED_SECTORS set to true while ALLOW_DYNAMIC_RESTRICTED_ROAMING set to false. Any other combination produces either weird results or greys out whole map in the 'r' screen.

I do remember using this when Headrock introduced this for his HAM mod. Right now I see no way to use it so it's probably broken.

Btw, I tried using it with 5520 .exe version, the one released on SVN but the problem is the same.
Could it be that some change in hotkeys broke right click functionality in 'r' screen?
Re: BUGZILLA report all bugs here![message #311812] Mon, 05 November 2012 23:38 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
@Parkan: The tooltip error is corrected in r5669.


Re: BUGZILLA report all bugs here![message #311827] Tue, 06 November 2012 11:53 Go to previous messageGo to next message
Parkan

 
Messages:436
Registered:April 2010
Location: Russia,Sevastopol

thank you =)
Re: BUGZILLA report all bugs here![message #312028] Tue, 13 November 2012 21:17 Go to previous messageGo to next message
Uriens

 
Messages:340
Registered:July 2006
Some more bugs. Using latest version from SVN 1559 and exe version is 5685.

Using inventory popups bug. If you try to attach something that is forbidden an error will appear as normal but after that any action results in crash.

Latest crash report caused by this:
Toggle Spoiler


Cowers in fear prone animations seems to be bugged sometimes. Enemy can become unhittable by any attacks (ranged, melee, explosives) until he recovers and gets out of that stance. Doesn't happen all the time but it's frequent enough to be a problem. This seems to most often happen to enemies that got suppressed by grenades, like stun grenade.
Cowers in fear crouch animations can also become bugged but in different way. This seems to happen when militia kills an enemy - he will instead of becoming a corpse just remain there in 'cowers in fear' stance with dying status. Militia will ignore him and move on while mercs can see him AND they can target/shoot him to finish him off. If not finished enemy can stay like this forever. Reminds me a lot on that falling from rooftop animation bug except that you can't target or kill enemy there (I think).

[Updated on: Tue, 13 November 2012 21:25] by Moderator

Re: BUGZILLA report all bugs here![message #312029] Tue, 13 November 2012 21:30 Go to previous messageGo to next message
DepressivesBrot

 
Messages:3698
Registered:July 2009
Roofzombies can be targeted and killed with melee attacks.
Did you get the bug where a soldier 'cowers in fear' but instead stands (making him an easy target) up as well?


Re: BUGZILLA report all bugs here![message #312030] Tue, 13 November 2012 21:54 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
Does that happen on all bodytypes, or just on single one? Stuff like this can happen if some animation is missing.


Re: BUGZILLA report all bugs here![message #312032] Tue, 13 November 2012 22:51 Go to previous messageGo to next message
Uriens

 
Messages:340
Registered:July 2006
Not sure what body type it was. It looked like normal male I think. The animation was there, he had cower in fear stance, crouched one. I'll pay attention to body type next time I ran into it.

I get soldier 'stands up' bug all the time. It's in fact so often I figured you guys know about it for sure. It seems like it's some sort of 'mid stance'. First shots get him up, next ones get him to normal cower stance (assuming he didn't die while standing). I'm playing with AIMNAS and increased suppression effects so I see this quite often.
Re: BUGZILLA report all bugs here![message #312096] Thu, 15 November 2012 14:59 Go to previous messageGo to next message
Uriens

 
Messages:340
Registered:July 2006
Ok, here is an update:

Quote:
Cowers in fear crouch animations can also become bugged but in different way. This seems to happen when militia kills an enemy - he will instead of becoming a corpse just remain there in 'cowers in fear' stance with dying status. Militia will ignore him and move on while mercs can see him AND they can target/shoot him to finish him off. If not finished enemy can stay like this forever.


I ran into this again - twice. It was on an enemy with normal male body, but I don't think it's really important. I think I figured out what may cause this.
Both times it happened during militia turn. It may be possible for this to happen on enemy turn against militia (or even your mercs), but I didn't see it yet. The first time it happened when a militia was shooting at the enemy and, while the animation of cover in fear was still playing for that enemy, another militia came to turn and shot that enemy (would probably killed him). However, that made enemy status stuck in dying state.
Second time it happened when ambidextrous militia with 2 pistols was shooting at the enemy that already had 'cower in fear' stance. Both shots were hits, first one started animation of being hit while cowered in fear and before that animation ended, another shot landed and send him to this frozen dying state.

It would seem that problem appears when a killing shot lands while the animation is playing. In both cases hits happened shortly after first move before animations finished. I'm guessing that in code, at the end of animation, game calls for something that causes this.

All this happened only on crouched cower in fear animations. Never saw this on any other stance.



I also ran into another bug. If your merc is positioned behind the door that blocks view of him, when he tries to apply first aid on him you will get a stopwatch and action wont happen. I do recall that this specific action (first aid) had problems before in much older versions if there were objects (not only doors) in the way when you clicked on your merc. This bug is still here.
I think this one should be easy to reproduce, just have your merc stand behind an object like door and try to make him apply first aid on himself. You may have to hit him with something first so that he actually has something to heal.



Also, stand up bug appears to happen on prone enemies/militia/mercs when they are prone and under suppression fire. On first shot/burst they stand up and on next (assuming they live) they go to crouched 'cower in fear' stance. I'm not sure if the problem is that game decides to send prone targets to crouched cower in fear stance (which is wrong stance for prone targets), or the prone 'cower in fear' animation fails to start and the game then sends them to standing stance as a backup. I must mention that I really don't remember seeing enemy going to prone 'cower in fear' stance from prone position under suppression fire. Only times I saw enemy go to prone 'cower in fear' was because of grenade explosion.
Re: BUGZILLA report all bugs here![message #312210] Sun, 18 November 2012 22:30 Go to previous messageGo to next message
wolf00

 
Messages:1147
Registered:September 2006
Location: Czech Republic

i have a merc on repair duty,when is my repair kit deplet game going to asertion fail... latest svn revision & exe 5676
Re: BUGZILLA report all bugs here![message #312223] Mon, 19 November 2012 01:34 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
Thank you for spotting that. Fixed in r5693.


Re: BUGZILLA report all bugs here![message #312246] Mon, 19 November 2012 10:50 Go to previous messageGo to next message
wanne (aka RoWa21)

 
Messages:1974
Registered:October 2005
Location: Austria
Map editor crash on saving map I13. Present in 4870 & 5520 (spotted by Buggler)
Load the map I13 in the map editor & save without any changes will cause CTD.


Re: BUGZILLA report all bugs here![message #312260] Mon, 19 November 2012 20:43 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
Testing that one with r5693. It crashes because of something happening in ClassifyEdgepoints() in Map Edgepoints.cpp:787... something about isolated gridno handling, whatever that is.

So far, I feel pretty innocent about it, as I didn't do anything there...

Update: This is somehow connected to map entry points, and the fact that this map in particular has fences that limit the possible merc entrypoints from north and east. If you tell the game that the map has no gMapInformation.sNorthGridNo and gMapInformation.sEastGridNo, everything works, one can save this... ideas, anyone? Has anyone observed similar behaviour in other maps?

Update 2: That definetly is the problem. If I remove a tiny section of the fence, the map can properly be saved. I conclude that the game tries to check wether the map edgepoints are connected to... some other region. If the fence is closed, this isnt possible... and the code cannot handle that. Atm no idea how to fix that. Putting a whole in your fence will solve this issue, but is kinda against the concept of fences, isn't it?

Update 3: If the fence is there, we try ClassifyEdgepoints() (isn't it wonderful if a code section begins with Quote:
There is a flaw in the design of this system.
? On checking the northern gridno, we try InternallyClassifyEdgepoints(). Stuff happens, dunno if good or bad , but in the end a MemReallocReal() fails because of HeapValidate()-error... ehem. Ideas? Anyone?

[Updated on: Mon, 19 November 2012 23:15] by Moderator



Re: BUGZILLA report all bugs here![message #312273] Mon, 19 November 2012 23:47 Go to previous messageGo to next message
wanne (aka RoWa21)

 
Messages:1974
Registered:October 2005
Location: Austria
the fact, that the bug is still present in 4870 makes it hard to spot the code which caused the bug. can we get a workaround even if it us dirty to catch that bug and allow the saving of the map?


Re: BUGZILLA report all bugs here![message #312276] Tue, 20 November 2012 02:16 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
Removing a part of the fence makes the map saveable. Alternatively, removing the isolated entry point might also work, but I did not test that.


Re: BUGZILLA report all bugs here![message #312282] Tue, 20 November 2012 09:03 Go to previous messageGo to next message
Buggler

 
Messages:209
Registered:November 2009
On further testing, G1 & H1 also CTD on saving in map editor w/o doing anything as they too hav e isolated entry.

E weird thing is I14 can b edited & saved successfully... (which also hav isolated entry point accessible only from adjacent sectors)
Re: BUGZILLA report all bugs here![message #312294] Tue, 20 November 2012 19:16 Go to previous messageGo to next message
Clarkew

 
Messages:75
Registered:May 2011
Location: East Texas, USA
SVN Rev 1564 Ex build 5679

Just had a soldier standing on the other side of the chitzena wall(A2) (and ten+ tiles away) kick my imp to near death with one hit
Re: BUGZILLA report all bugs here![message #312296] Tue, 20 November 2012 19:31 Go to previous messageGo to next message
Sam Hotte

 
Messages:1995
Registered:March 2009
Location: Middle of Germany
Must have been Chuck Norris ... Wink

SCNR
Re: BUGZILLA report all bugs here![message #312297] Tue, 20 November 2012 19:56 Go to previous messageGo to next message
Clarkew

 
Messages:75
Registered:May 2011
Location: East Texas, USA
lmao. Surprised the wall didn't fall down too.
Re: BUGZILLA report all bugs here![message #312299] Tue, 20 November 2012 21:05 Go to previous messageGo to next message
Flugente

 
Messages:3538
Registered:April 2009
Location: Germany
I14 does not have a closed fence, thus the difference. Closed fences are a no-no, it seems.

Hmm... dunno. Must be because the enclose part is smaller, thus something does not happen here...

Update: I've checked I14. Funny thing: I can save it once without any problems... but if I save that map again, I get the same crash. What happens is that on the first saving, gus2ndNorthEdgepointArraySize has size 82, but on the second saving, it has size 121. when trying to allocate memory, this immediately fails.

This is all very odd. As I'm pretty saved we do not do randomized saving :headbanger:, this means that either
  • some code section gets overwritten somewhere :roulette:
  • or those arrays (or their sizes) are not cleaned properly... which is very odd, considering the fact that saving a map is a very basic thing we do since ages. I know of no changes to entry points whatsoever... :dontknow2:

Update2: The funniest thing ever happened: When we do our little... whatever, we call a function that has this little gem:
if( gWorldSectorX == 14 && gWorldSectorY == 9 && !gbWorldSectorZ )
{ //BRUTAL CODE	-- special case map.
	iSearchRange = 250;
}
else
{
	iSearchRange = EDGE_OF_MAP_SEARCH;
}


:computer2:

Update3: If I remove that special case thing for I14, the map saving crashes the first time, reproducable. So the above is good for something... but there is no comment on what that might be. :wb:

[Updated on: Wed, 21 November 2012 03:05] by Moderator



Re: BUGZILLA report all bugs here![message #312341] Thu, 22 November 2012 18:30 Go to previous messageGo to next message
Uriens

 
Messages:340
Registered:July 2006
Exe version: 5695
Svn version: 1564

Just a short update on a standing up when cowering bug.

I can now confirm that this happens when the target is in the prone ready stance and gets suppressed by enemy fire. Instead of going to cower stance he stands up.

Also, if the target is in lying on the floor position (stunned by grenade, out of energy bc of shotgun hit, fell from a hit in the legs, etc.) he will move to lying cower stance properly without standing up.

Most likely cause of this is that there is a bug that prevents target to go from prone stance into lying cower stance directly and instead target stands up.

This happens every time a prone target gets suppressed by enemy fire and it appears to be a case for both prone stance with a rifle and a prone stance with a pistol (not 100% sure if same applies to dual pistols).
Re: BUGZILLA report all bugs here![message #312348] Fri, 23 November 2012 00:38 Go to previous messageGo to next message
pyg

 
Messages:42
Registered:August 2007
I've been getting a consistent crash removing an attachment from an item (like nvg from helmet, scope from rifle) from 5520/recent svn to DepressivesBrot 5699/1562 sci. It doesn't happen at first but by the time I get to Drassen at some point I go to change something and I get a assertion error crash. I would do the bugzilla thing but I couldn't find a .sav (they didn't move recently right?). Also, the Shift-n goggle swap doesn't work then... usually how I crash it is by trying to manually change eye gear.

[Updated on: Fri, 23 November 2012 00:38] by Moderator

Re: BUGZILLA report all bugs here![message #312400] Sat, 24 November 2012 15:04 Go to previous messageGo to previous message
knightofni

 
Messages:98
Registered:August 2011
exe : 5676
svn : 1554

(Depressive Bot SCI), using no Mods.

The PercentBase modifier (modifier for snapshot) doesn't seem to be working. It works in the official release (4870).
The reticule is similar with -99% and +99%. With 4870, the difference in the reticule is easily noticeable.

Previous Topic: 1440x900 resolution bug.
Next Topic: Mine income adjustment range
Goto Forum:
  


Current Time: Sun Aug 01 04:54:33 EEST 2021

Total time taken to generate the page: 0.03769 seconds