Home » SIRTECH CLASSICS » Jagged Alliance: Unfinished Business » JA2:UB General Talk » Saving issue (Game needs long time to save)
Saving issue[message #365546] Mon, 24 July 2023 19:31 Go to previous message
Sim0n_187 is currently offline Sim0n_187
Registered:July 2022
Hello everybody!

After installing Windows 10 and Unfinished Business on my computer there is a problem with saving games in Unfinished Business. I started a new game where it normally should run very fast. I'm in the second sector and I get a delay about 5 seconds until I could save a game via alt+s or ctrl+s. When I load a saved game it's very fast instead.
So I also tried saving and loading on my old savegames in JA2 1.13 where I'm shortly before Meduna. There it is no problem to save or load the game. I read somewhere that a savegame which is far progressed in the game could take a bit longer but like this it doesn't make any sense.

The reason why I installed Unfinished Business is that I want to try out some mods like B2B soon but when saving is like this it's useless. For being able to play the Jagged Alliance games at correct speed in Windows 10 I use the 3 .dll-files (ddraw.dll, libwine.dll and wined3d.dll). When I don't have the three .dll-files in the gamefolder saving isn't better in UB. I also tried to delete and reinstall the game in another folder (because of possible issues with x86).
So my question is: What can I do to have a normal saving time in Unfinished Business? Maybe someone has another good hint here.
I heard from the software SoftPerfect RAM Disk which I'll maybe try out.


[Updated on: Mon, 24 July 2023 19:34]

Report message to a moderator

Read Message
Read Message
Previous Topic: Change Language UB 1.01
Goto Forum:

Current Time: Wed Apr 17 14:54:19 GMT+3 2024

Total time taken to generate the page: 0.00719 seconds